The minimum encryption level set in a Citrix policy for Citrix MetaFrame for Windows Server 2003 is not enforced (822110)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When a Citrix Independent Computing Architecture (ICA) Client connects to Citrix MetaFrame for Windows Server 2003 on a Microsoft Windows Server 2003-based computer, the minimum encryption level set in a Citrix policy in the Citrix Management Console is not enforced by WinLogon on the Windows Server 2003-based computer.

For example, if you create a policy for a Citrix user to connect by using 128-bit encryption only, the user can still use "Basic" encryption to connect to Citrix MetaFrame for Windows Server 2003.

CAUSE

This problem will occur because WinLogon establishes an encryption level with the Citrix ICA Client before it obtains the encryption settings from a Citrix policy. Therefore, WinLogon ignores the encryption settings in the Citrix Policy.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name	Platform
   ---------------------------------------------------------------------
   02-Jul-2003  23:05  5.2.3790.67       632,832  Winlogon.exe     IA-64


   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   04-Jul-2003  00:01  5.2.3790.67       538,112  Winlogon.exe     

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB822110 kbAudITPRO