Network Discovery Data Discovery Records Are Rejected After You Apply Systems Management Server 2.0 Service Pack 5 (822068)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0 SP5

SYMPTOMS

After you install Microsoft Systems Management Server (SMS) 2.0 Service Pack 5 (SP5), the SMS Data Discovery Manager (DDM) may reject the Data Discovery Records (DDRs) that network discovery generates. You may receive a status message ID 2622 in the SMS Administrator console.

The Ddm.log file in the \SMS\logs folder may contain log entries that are similar to the following log entries:
...
Processing file cfhj8901.DDR
CDiscoveryProperty::Validate - String property "Subnet Name" exceeds stated maximum length of 20
CDiscoveryItem::ParseMem - Property "Subnet Name" is invalid.
CDiscoverDataManager::ProcessDDRs_PS - parsing failed. Processing NEW <IP Network>...
CDiscoverDataManager::ValidateItemName - no valid name properties found
...

CAUSE

This behavior occurs because SMS 2.0 SP5 enhances the DDR integrity checking capabilities of DDM. These enhancements prevent DDM from processing malformed records. In earlier versions of SMS 2.0, if a DDR field name is longer than the expected maximum length, DDM truncates it to the expected minimum length and processes it correctly.

For example, the Dynamic Host Configuration Protocol (DHCP) Scope Name has an expected maximum length of 20 characters. In versions of SMS 2.0 before Service Pack 5, DDM truncates the Scope Name to 20 characters and processes the DDR. After you install SMS 2.0 SP5, DDM rejects the DDR.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ---------------------------------------------------------------------------   
   16-Jun-2003  19:26  2.0.4.1        252,715  Sms2.0-sp5-kb822068-x86-enu.exe   
   25-Feb-2003  16:05  2.0.1493.5134   49,648  Netdisc.dll      
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in SMS 2.0 Service Pack 5.

MORE INFORMATION

After you apply this hotfix, the length of a field in a DDR adapts up to a maximum of 255 characters. DDM does not truncate the DDRs when it processes them.

How to Install the Hotfix

To install the hotfix, use one of the following methods, as appropriate.

Method 1: Use the Hotfix Installer

Note This method is for Intel-based computers only.
  1. Copy the hotfix folder structure to a share on your network. Sms2.0-sp5-kb822068-x86-enu.exe is a Microsoft Windows Installer file that updates specific files on your site server.
  2. Use an account that has administrative credentials to log on to your site server.
  3. On the site server, quit the SMS Administrator console.
  4. Run the Sms2.0-sp5-kb822068-x86-enu.exe file and follow the directions in the wizard.

Method 2: Install the Hotfix Manually

To install the hotfix, follow these steps on the SMS site server:
  1. Stop the SMS Site Component Manager and SMS Executive services.
  2. Replace the Netdisc.dll file in the SMSRootFolder\Bin\I386 folder with the version that you obtained from the hotfix.
  3. Restart the SMS Site Component Manager and the SMS Executive services.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMS200preSP6fix kbfix kbbug KB822068 kbAudITPRO