NTBackup Does Not Run As Expected When You Run It from a Command Prompt (821730)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you use a command prompt or a batch file to run the NTBackup utility, and you include command-line parameters with the ntbackup command, NTBackup does not run as expected.

CAUSE

This problem occurs if you use a slash character and a letter in the following combinations as part of a parameter for a switch:

/j
/p
/g
/t
/n
/f
/d
/ds
/is
/a
/v
/r
/l
/m
/rs
/hc
/um

NTBackup reads each of these character combinations as if it were another switch itself (instead of just part of a switch parameter).

For example, in the following command syntax, the parameter that is used with the /d switch contains the "/r" character combination. This character combination is read by NTBackup as the /r switch instead of as part of the /d parameter:

ntbackup backup "@d:\backup.bks" /j "test backup job" /f "d:\backup.bkf" /d "backup set label /r" /a /v:yes /m copy /hc:off

If this command were to include the /r switch in the syntax, this problem would not occur. For example, in the following command syntax, the /d parameter still contains the "/r" character combination. However, because the /r switch is also clearly stated in the syntax, the problem does not occur:

ntbackup backup "@d:\backup.bks" /j "test backup job" /f "d:\backup.bkf" /d "backup set label /r" /a /v:yes /r:no /m copy /hc:off

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date         Time        Version          Size   File name
  -------------------------------------------------------------
  17-Jul-2003  05:48    5.2.3790.69     1,168,384  Ntbackup.exe 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB821730 kbAudITPRO