Cannot Install the Exchange System Management Tools on a Server That Is Running Windows Server 2003 (821507)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you try to install the Microsoft Exchange System Management Tools on a server that is running Microsoft Windows Server 2003, you may receive one of the following error messages:
The component "Microsoft Exchange System Management Tools" cannot be assigned the action "Install" because:
- The Windows 2000 Administrative Tools must be present.
You cannot install this product on a computer running Windows 2000 Professional

CAUSE

This issue may occur if either of the following conditions is true:
  • You try to install the Exchange System Management Tools on a member server after you raise the domain functionality setting to Windows Server 2003.

    -or-
  • You try to install the Exchange System Management Tools on a member server that you have promoted to the role of domain controller (dcpromo) and then demoted to the role of member server.
The Exchange Server Setup operation is unsuccessful because an incorrect operating system type is returned by the NetServerGetInfo() request.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

x86

Date         Time   Version            Size    File name
---------------------------------------------------------
22-May-2003  18:13  5.2.3790.35        89,600  Srvsvc.dll

IA-64

Date         Time   Version            Size    File name
---------------------------------------------------------
22-May-2003  18:04  5.2.3790.35       192,512  Srvsvc.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB821507 kbAudITPRO