Access Violation Error in Nwssvc.exe When Starting File and Print Services for Netware on a Windows 2000-Based Computer (818195)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Professional SP4
  • Microsoft Windows 2000 Professional SP3

SYMPTOMS

When you start File and Print Services for NetWare on a computer that is running the Japanese version of Microsoft Windows 2000, you may experience an access violation error in Nwssvc.exe.

Note This problem may also occur on a computer that is running the English version of Microsoft Windows 2000 and that has the Microsoft Office 2000 MultiLanguage Pack for Japanese installed.

CAUSE

This problem may occur when you use a custom printer form that contains both double-byte character set (DBCS) and single-byte character set (SBCS) characters (for example, both Japanese and English characters).

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   02-May-2003  18:44  5.0.2195.6742     214,800  Fpnw.dll         
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product


Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbQFE kbfix kbbug KB818195 kbAudEndUser