The option in the Authentication dialog box to connect to the Exchange server by using a smart card is not supported in Outlook 2003 (817971)



The information in this article applies to:

  • Microsoft Office Outlook 2003

SYMPTOMS

When you connect to your Microsoft Exchange server, there is an option in the Authentication dialog box to connect by using a smart card. When you click Insert smartcard, and then type your smart card credentials, you appear to be authenticated, even though you are not prompted for a smart card personal identification number (PIN). However, typical Exchange server features do not work. For example, you do not receive notification of new items from the Exchange server, and you cannot send new items. You can only work with local cached items.

CAUSE

This problem occurs if all the following conditions are true:
  • You connect to Microsoft Exchange Server 2003 over the Internet by using Hypertext Transfer Protocol (HTTP). For more information about how to connect to Exchange 2003 over the Internet, see the "More Information" section of this article.

    -and-
  • Exchange 2003 is using basic password authentication.

    -and-
  • You have a smart card reader that is connected to your computer.
This problem occurs because the option in the Authentication dialog box to connect to the Exchange Server by using a smart card is not supported in Microsoft Outlook. Microsoft Windows offers this option incorrectly.

When you select the option in the Authentication dialog box to connect to the Exchange Server by using a smart card, Outlook starts by using Cached Exchange Mode. This is a new Microsoft Exchange account configuration for Outlook. With this new account configuration, you can connect to an Exchange server to cache a copy of your Exchange Server mailbox locally on your hard disk. For more information about Cached Exchange Mode, see the "More Information" section of this article.

RESOLUTION

To resolve this problem, do not select the option in the Authentication dialog box to connect to the Exchange Server by using a smart card when you connect to the Exchange Server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Cached Exchange Mode

The Cached Exchange Mode feature requires that you use an Exchange Server e-mail account in Cached Exchange Mode.

The Cached Exchange Mode feature can give you a better experience when you use an Exchange Server e-mail account. A copy of your mailbox is stored on your computer. This copy provides quick access to your data, and it is frequently updated with the mail server.

If you work offline, whether by choice or because of a connection problem, your data is still available to you instantly wherever you are. If a connection from your computer to the computer that is running Exchange Server is not available, Outlook switches to Trying to connect or Disconnected. If the connection is restored, Outlook automatically switches back to Connected or Connected (Headers). Any changes that you made while a connection to the Exchange Server was not available are synchronized automatically when a connection is available. You can continue to work while changes are synchronized.

How to Connect to Microsoft Exchange Server over the Internet

The Remote Procedure Calls (RPC) over Hypertext Transfer Protocol (HTTP) feature requires that you use an Exchange Server 2003 e-mail account. If you do not know what version of Exchange Server your e-mail account is using, contact your Exchange Server administrator.

In a local area network (LAN) environment, Outlook communicates with the Exchange Server by using remote procedure call (RPC) with TCP/IP. This method provides quick, efficient access for a corporate network. However, in previous versions of Exchange Server and Outlook, access to an Exchange Server by remote users required a virtual private network (VPN) connection to the corporate network. A VPN provides a remote user with a connection in an organization's corporate network and in its firewall. A VPN enables access to more network services than is required for just e-mail access.

For remote connections, Outlook now offers an alternative to VPN connections. Outlook can connect to an Exchange Server through the Internet by using RPC over HTTP. With the RPC over HTTP feature, you can access your Exchange Server account remotely from the Internet when you are working outside your organization's firewall without any special connections or hardware, such as smart cards and security tokens.

The following are the minimum requirements to use this feature:
  • Microsoft Windows XP Service Pack 1 (SP1) with the updates that are included in the following Microsoft Knowledge Base article installed, or a later service pack:

    331320 Outlook 2003 Performs Slowly or Stops Responding When Connected to Exchange Server 2003 Through HTTP



    -and-
  • Exchange Server 2003 that is running on Microsoft Windows Server 2003.

    -and-
  • Your Exchange Server administrator must have configured the server to permit connections through HTTP.
For more information about how to configure the RPC over HTTP feature, see the Microsoft Office Resource Kit and the Microsoft Exchange Server documentation.

Modification Type:MinorLast Reviewed:1/6/2006
Keywords:kbtshoot kbConfig kbprb kbnofix KB817971 kbAudEndUser