Smigrate error accessing service.cnf during backup of rootweb in Office 2003 and Windows SharePoint Service (817932)



The information in this article applies to:

  • Microsoft Office Professional Edition 2003
  • Microsoft Office FrontPage 2003
  • SharePoint Team Services from Microsoft
  • Microsoft Windows SharePoint Services

SYMPTOMS

When you use the Smigrate tool to backup the rootweb, the following four errors are recorded in the event log on the server:
Type: Warning
User: N/A
Source: FrontPage 5.0
Category: None
Event ID: 1000

Microsoft FrontPage Service Extensions:
  http://rootweb - Error #20005d Message: The server extensions were unable to access the file "service.cnf". Please check the file permissions.
Type: Warning
User: N/A
Source: FrontPage 5.0
Category: None
Event ID: 1000

Microsoft FrontPage Service Extensions:
  (OS Error #13 Message: Permission denied)
Type: Warning
User: N/A
Source: FrontPage 5.0
Category: None
Event ID: 1000

Microsoft FrontPage Service Extensions:
  http://rootweb - Error #20005d Message: The server extensions were unable to access the file "service.cnf". Please check the file permissions.
Type: Warning
User: N/A
Source: FrontPage 5.0
Category: None
Event ID: 1000

Microsoft FrontPage Service Extensions:
  (OS Error #13 Message: Permission denied)
No errors are recorded in the Smigrate backup log file.

CAUSE

This problem occurs because of the implementation of the Web Extender Client (WEC). When you use the -u and -pw parameters with the Smigrate tool, the -u and -pw specification is processed only after default authentication has failed.

MORE INFORMATION

The WEC first tries to authenticate as anonymous, then as the logged in user, and finally as the user specified by the -u parameter. If authentication as both anonymous and the currently logged on user fails, the user specified with the -u parameter is used. If the logged in user authenticates, the Smigrate command is run as the logged in user and the -u and -pw parameters are ignored.

For example:

Authentication fails if you are logged in as domainname\username1, and then you run the following command:

smigrate -w http://rootwebtest -f junk.fwp -e -y -u domainname\username2 -pw password

Authentication is successful if you are logged in as domainname\username1, and then you run the following command:

smigrate -w http://rootwebtest -f junk.fwp -e -y

This problem occurs because username1 is an administrator on the computer, and username2 is not. Authentication is successful if you give the user username1 full permissions to the Service.cnf file, and then log on to the computer as username1 to run the Smigrate command.

WORKAROUND

To work around this problem, follow these steps:
  1. Click Start, and then click Control Panel.
  2. If you are using Classic View, double-click Internet Options.

    If you are using Category View, click Network and Internet Connections, and then click Internet Options.
  3. Click the Security tab, and then click the Web content zone for your server.
  4. Click Custom Level, and then scroll down to User Authentication.
  5. Under Logon, click Prompt for user name and password.
This prevents Internet applications from authenticating as the logged in user, forcing WEC to authenticate as the user specified with the -u and -pw parameters.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:9/27/2006
Keywords:kbCommandLine kbwebpublishing kberrmsg kbUser kbSecurity kbnofix KB817932 kbAudITPRO kbAudEndUser