The Internet Connection Firewall (ICF)/Internet Connection Sharing (ICS) Service Starts and Runs Unexpectedly After You Upgrade to Small Business Server 2003 (817876)



The information in this article applies to:

  • Microsoft Windows Small Business Server 2003, Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition

SYMPTOMS

After you upgrade a Microsoft Windows 2000 Server-based computer to Microsoft Windows Small Business Server 2003, you may find that the Internet Connection Firewall (ICF)/Internet Connection Sharing (ICS) service starts and runs unexpectedly.

CAUSE

This issue occurs if Internet Connection Sharing is enabled on the Windows 2000 Server-based computer. In this situation, the Internet Connection Firewall (ICF)/Internet Connection Sharing (ICS) service starts and runs on the computer after you upgrade to Windows Server 2003 for Small Business Server even though the Internet Connection Sharing feature is not included with Windows Server 2003 for Small Business Server.

WORKAROUND

To work around this problem, disable the Internet Connection Firewall (ICF)/Internet Connection Sharing (ICS) service. To do so, use one of the following methods.

Method 1: Use the Net Stop Command

To disable the Internet Connection Firewall (ICF)/Internet Connection Sharing (ICS) service by using the net stop command:
  1. Click Start, and then click Run.
  2. In the Open box, type cmd, and then press ENTER.
  3. Type the following line at the command prompt, and then press ENTER:

    net stop sharedaccess

  4. Type exit to close the command prompt window.

Method 2: Use the Services Tool

To disable the Internet Connection Firewall (ICF)/Internet Connection Sharing (ICS) service by using the Services tool:
  1. Click Start, point to Administrative Tools, and then click Services.
  2. In the list of services, right-click Internet Connection Firewall (ICF)/Internet Connection Sharing (ICS), and then click Properties.
  3. Click the General tab.
  4. In the Startup type box, click Disabled, and then click OK.

Modification Type:MinorLast Reviewed:10/8/2003
Keywords:kbbug KB817876 kbAudITPRO