Computer stops responding with "Stop 0x000000D1 Driver_IRQL_Not_Less_Or_Equal" error message (817789)



The information in this article applies to:

  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

SYMPTOMS

Your Windows Server 2003-based computer may stop responding and you may receive a Stop error message that is similar to the following:

STOP 0x000000D1 (0x0000000, 0x00000002, 0x00000000, 0xF730B0a2) Driver_IRQL_Not_Less_Or_Equal

CAUSE

This problem may occur if all of the following conditions are true:
  • Third-party enterprise storage management software is installed on the computer.
  • You are using the Storport.sys storage driver.
  • Windows Server 2003 incorrectly processes the Startlo routine in Storport.sys.

RESOLUTION

Hotfix Information

The following file is available for download from the Microsoft Download Center:
DownloadDownload the 823728 package now.
64-Bit versionA supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.
This hotfix applies to English, French, German, Spanish, Traditional Chinese, Simplified Chinese, Korean, and Japanese-language versions of Windows Server 2003.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version      Size     File name      Platform
-----------------------------------------------------------------
15-Oct-2003  20:19  5.2.3790.92   71,168  Storport.sys        x86
15-Oct-2003  17:19  5.2.3790.92  248,320  Storport.sys      IA-64
15-Oct-2003  18:15  5.2.3790.83   29,696  Wmspatcha.dll     IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kberrmsg kbfix kbQFE kbWinServ2003preSP1fix kbbug KB817789