Computer Stops Responding When Running BPStress.exe, Error in UsbhFdoCleanup Process (817686)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

SYMPTOMS

BPStress.exe is part of the Hardware Compatibility Test (HCT) Fault Tolerant test kit. When you run BPStress.exe, the computer may stop responding and you may receive a "bugcheck" error message on the UsbhFdoCleanup process.

CAUSE

This behavior may occur when BPStress.exe causes a failure on a node during the stress test, and then moves to a backup node. During this failover mode, the USB host controllers and root hubs are removed, and this causes the error.

No USB devices must be attached to the computer for this error to occur.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   ----------------------------------------------------------------
   31-Mar-2003  18:08  5.2.3790.2         54,784  Usbhub.sys
   29-Mar-2003  02:41                        211  Branches.inf
   31-Mar-2003  19:32                     10,091  Kb817686.cat
   31-Mar-2003  19:17                        354  Updatebr.inf
   31-Mar-2003  19:18                      5,136  Update_rtmqfe.inf

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB817686 kbAudITPRO