"Setup is unable to determine the DNS name of this computer. See Microsoft Knowledge Base article 817543" error message when you run Exchange Server 2003 Setup (817543)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition



SYMPTOMS

When you run Microsoft Exchange Server 2003 Setup, you may receive an error message that is similar to the following message:

Setup is unable to determine the DNS name of this computer. See Microsoft Knowledge Base article 817543 at http://support.microsoft.com for information about how to correct this problem, and then run Setup again.

CAUSE

This issue may occur if the dNSHostName attribute of the server is not set in the Active Directory directory service. When a computer joins an Active Directory domain, Active Directory stores the fully qualified domain name (FQDN) of the computer and the computer account name in the dNSHostName attribute. Exchange Server 2003 Setup determines the FQDN of the server from the dNSHostName attribute. In certain situations where you upgrade your Microsoft Windows NT 4.0 domain to a Microsoft Windows 2000 domain or to a Microsoft Windows Server 2003 domain, this attribute may not be set.

RESOLUTION

To resolve this issue, set the dNSHostName attribute by using one of the following methods:
  • Restart the server.
  • Use the nltest /sc_reset:DomainName command. To do so:
    1. Click Start, and then click Run.
    2. In the Open box, type cmd, and then click OK.
    3. At the command prompt, type nltest /sc_reset:DomainName, where DomainName is the name of the domain, and then press ENTER.

MORE INFORMATION

For additional information about the dNSHostName attribute, click the following article number to view the article in the Microsoft Knowledge Base:

240942 Active Directory DNSHostName property does not include subdomain


Modification Type:MinorLast Reviewed:11/7/2005
Keywords:kbfix kbBug KB817543 kbAudITPRO