XADM: Store.exe Stops Responding and Generates a Dr. Watson Error Report (817452)



The information in this article applies to:

  • Microsoft Exchange Server 5.5 SP4
  • Microsoft Exchange Server 5.5 SP3
  • Microsoft Exchange Server 5.5 SP2
  • Microsoft Exchange Server 5.5 SP1
  • Microsoft Exchange Server 5.5

SYMPTOMS


Store.exe on your Exchange Server computer stops responding and generates a Dr. Watson error report.

CAUSE

This problem may occur when a third-party mail client (for example, Netscape Communicator or a UNIX client) sends a LOGOUT command to the Exchange Server computer, and then immediately sends a hard disconnect of the socket that is used for communication. The hard disconnect closes the connection before the LOGOUT command has completed. The problem occurs because the Exchange Server computer cannot communicate over the NULL connection.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange 5.5 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. Component: Information store

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   --------------------------------------------------
   01-Apr-2003  19:29  5.5.2657.35       491,280  Mdbmsg.dll
   01-Apr-2003  19:32  5.5.2657.35     2,628,880  Store.exe

				
Note Because of file dependencies, this feature requires Microsoft Exchange Server version 5.5 Service Pack 4.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbinfo kbExchange550fix kbQFE kbfix kbbug KB817452 kbAudITPRO