Image files do not appear when you view a Web page with Internet Explorer 6 SP1 (817177)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows XP SP1
    • the operating system: Microsoft Windows 2000 SP2
    • the operating system: Microsoft Windows 2000 SP3
    • the operating system: Microsoft Windows NT 4.0 SP6a
    • the operating system: Microsoft Windows Millennium Edition
    • the operating system: Microsoft Windows 98 Second Edition

SYMPTOMS

When you use Internet Explorer 6 Service Pack 1 (SP1) to view a Web page that contains image files, you may experience the following behavior:
  • Some of the images do not appear on the Web page.
  • Internet Explorer may no longer display images until you restart the program.

CAUSE

Internet Explorer cannot recognize the end of the header area of an image file if the end of the header area is at the end of the buffer when the image is loading. Therefore, Internet Explorer cannot display the image because it cannot recognize when the image has been completely downloaded.
Note Internet Explorer always uses its internal buffer for loading data. The buffer size depends on the computer environment. Therefore, the buffer size dynamically changes. Users cannot fix the buffer size.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Explorer 6.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   --------------------------------------------------------
   31-Jul-2003  19:43  6.0.2800.1240  2,798,592  Mshtml.dll
Note Because of file dependencies, this hotfix requires Internet Explorer 6 Service Pack 1 (SP1).

For additional information about how to obtain the latest service pack for Internet Explorer 6.0, click the following article number to view the article in the Microsoft Knowledge Base:

328548 How to Obtain the Latest Service Pack for Internet Explorer 6



STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New naming schema for Microsoft Windows hotfix packages


The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbfix kbBug kbQFE KB817177 kbAudEndUser