XADM: Message Failed Re-Signing Operation Error When You Use the Sectool.exe Tool to Decrypt and Digitally Re-sign a Message (817169)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

SYMPTOMS

When you try to use the Bulk Advanced Security tool (Sectool.exe) to decrypt and re-sign messages that are both encrypted and digitally signed, you may receive the following error message:
Message "V1 encrypted; V1 signed" FAILED re-signing operation.
You cannot decrypt and then re-sign the message.

CAUSE

This behavior may occur if you use the Sectool.exe tool to try to decrypt and digitally re-sign messages that are in a personal storage (.pst) file before you have opened a message that is in that .pst file.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Component: Utilities

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Mar-2003  18:56  5.5.2657.33       269,584  Sectool.exe    
Note Because of file dependencies, this update requires Exchange Server 5.5 Service Pack 4 (SP4). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

191014 XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack

WORKAROUND

To work around this problem, use Microsoft Outlook to open a message that is in the personal storage (.pst) file before you use the Sectool.exe tool.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

When you use Outlook to open a message that is in the .pst file, several new MAPI properties are registered in the Top of Personal Folders MAPI folder. After these new MAPI properties are registered, the Sectool.exe tool can successfully re-sign the digitally signed messages.

During an unsuccessful decryption and re-signing operation, the Sectool.exe tool prompts you for a password one time (to decrypt the message), and then generates the error message that is described in the Symptoms section of this article. When the Sectool.exe tool successfully decrypts and re-signs a message, you are prompted for a password one time to decrypt the message, and then you are prompted for a password a second time to digitally sign the message.

Modification Type:MinorLast Reviewed:10/13/2005
Keywords:kbHotfixServer kbQFE kbExchange550preSP5fix kbQFE kbfix kbExchange2000preSP4fix kbbug KB817169 kbAudITPRO