Print Spooler Resource Stops Working on Windows Server Cluster (817154)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server

SYMPTOMS

In a Windows 2000 Advanced Server cluster or a Windows 2000 Datacenter Server cluster, the Print Spooler resource stops working, and you cannot print to your printer device.

CAUSE

This problem occurs because the name is not changed correctly in the cluster registry hive after you rename the Print Spooler resource in Cluster Administrator. When the Print Spooler resource is taken offline and then brought back online, the Print Spooler resource does not start.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   08-Apr-2003  16:41  5.0.2195.6683      55,568  Clusapi.dll      
   12-Mar-2003  15:02  5.0.2195.6683      67,760  Clusnet.sys
   08-Apr-2003  16:41  5.0.2195.6702     246,544  Clusres.dll      
   12-Mar-2003  15:02  5.0.2195.6683     682,768  Clussvc.exe      
   08-Apr-2003  16:41  5.0.2195.6680     134,928  Dnsapi.dll       
   08-Apr-2003  16:41  5.0.2195.6663      92,432  Dnsrslvr.dll     
   08-Apr-2003  16:41  5.0.2195.6660      95,504  Netman.dll       
   08-Apr-2003  16:41  5.0.2195.6604     477,456  Netshell.dll     
   12-Mar-2003  15:02  5.0.2195.6683      54,544  Resrcmon.exe     
   28-Mar-2003  17:50  5.0.2195.6680   3,988,992  Sp3res.dll       
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product


Modification Type:MinorLast Reviewed:1/4/2006
Keywords:kbHotfixServer kbQFE kbWin2000preSP4Fix kbfix kbbug KB817154 kbAudITPRO