Hardware inventory resynchronizes after you install the 328937 hotfix (816968)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0
  • Microsoft Systems Management Server 2.0 SP1
  • Microsoft Systems Management Server 2.0 SP2
  • Microsoft Systems Management Server 2.0 SP3
  • Microsoft Systems Management Server 2.0 SP4
  • Microsoft Systems Management Server 2.0 SP5

SYMPTOMS

After you install the original 328937 hotfix (Conv20.exe version 2.0.1493.4158) or after you install Systems Management Server (SMS) 2.0 Service Pack 5 (SP5), a Hardware Inventory resynchronization request may be generated if SMS Inventory Dataloader (Dataldr) tries to process a delta Management Information Format (MIF) file that contains an update for the Network Adapter Configuration class. When a later resynchronization MIF file is processed by Dataldr, the existing rows in the Network_DATA SQL table for that computer are not moved to history (the Network_HIST table). Instead, a new set of rows is inserted in the Network_DATA table. In the Resource Explorer tool, the "Hardware\Network Adapter Configuration" information shows all zeros for the Index column value for each computer. If a resynchronization has been processed, you see double entries for each computer. One set of entries contains all zeros for the Index value. The other set of entries contains the correct Index values.

You can run the following SQL command in the SQL Query Analyzer tool to verify the problem:

SELECT MachineID, Index0 FROM Network_DATA

Look for multiple rows for the same MachineID value with an Index0 value of zero.

CAUSE

The Index0 values in the Network_DATA table are set to zero after you install the 328937 hotfix (with Conv20.exe version 2.0.1493.4158) or after you install SMS 2.0 SP5. The Index0 values are set to zero because of a requirement to convert the data type for the Index0 column from a string (varchar) to an integer.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size  File name
   ------------------------------------
   28-Apr-2003  03:44  513   Update.sql
The German version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date          Time   Size  File name 
------------------------------------- 
30-May-2003  13:44    513  Update.sql



Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

How to Install the Hotfix

Using the Hotfix Installer

Note This method is only for Intel-based computers.
  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the Sms2.0-kb816968-spX-x86-enu.exe update file (where X is the service pack version) and platform folders to the new folder. The folder structure must be such that the update file is located one folder "above" the platform folders.
  3. On each of the primary SMS site servers, log on to your site server by using an account with administrator credentials.
  4. Quit the SMS Administrator console if it is running.
  5. Run Sms2.0-kb816968-spX-x86-enu.exe, and then follow the instructions in the wizard.
Note If you have multiple site servers in the same hierarchy that are experiencing this issue, install the fix on all the sites within the timeframe of the SMS Hardware Inventory interval. For example, if SMS Hardware Inventory is configured to run every seven days, install this fix on all the affected sites in the hierarchy within seven days to make sure that the NETWORK_DATA table is truncated on the site servers before clients start sending resynchronization MIF files. If you decide to manually force the resynchronizations, install the fix on all the affected site servers before you initiate the manual resynchronization. If you cannot install the fix on some sites within the appropriate timeframe, you may have to truncate the NETWORK_DATA table again to completely clean up the data that is associated with the Network Adapter Configuration class.

Using a Manual Installation

  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the platform folders that contain the hotfix files to the folder that you created.
  3. On each of the primary SMS site servers in your environment, log on to your site server by using an account with administrator credentials.
  4. Quit the SMS Administrator console if it is running.
  5. Stop all SMS services.
  6. Load the Update.sql script by using a SQL Server query tool such as Query Analyzer or ISQL/W.
  7. In the SQL Server query tool, click the SMS database, and then run the script.
  8. Restart the SMS services.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

WORKAROUND

To work around this problem, you can use the SQL truncate table command against the Network_DATA table to clear the data, and then allow resynchronizations to repopulate the table. As with any database procedure, Microsoft recommends that you first back up the database. The resynchronization process occurs automatically when Dataldr receives a delta MIF file from a client computer that contains an update for the Network Adapter Configuration class.

Because the Network Adapter Configuration class contains data (DefaultIPGateway, DHCPServer, IPAddress, IPSubnet, MACAddress, and others) that may not change frequently, you can force the resynchronization process to occur by modifying the master copy of the Sms_def.mof file that is stored on the site server in the SmsRootFolder\Inboxes\Clifiles.src\Hinv folder. Limit this modification to a small change (such as opening the file in a text editor, adding a space at the beginning of a blank line, and then saving the file) to force a new checksum.

You can also use the Invsync.exe to force a hardware resynchronization. The Invsync.exe tool is located on the SMS 2.0 CD-ROM in the Support\Reskit\Bin folder. More information about this tool is available in the Tools.htm file in the Support\Reskit folder.

MORE INFORMATION

The hotfix that this article describes performs the procedure that is described in the "Workaround" section of this article. As with any database procedure, Microsoft recommends that you back up the database before you apply this hotfix. Resynchronizations must occur to repopulate the Network_DATA table.

A later release of the 328937 hotfix is now available (Conv20.exe version 2.0.1493.4200). If you have not already installed the first release of the 328937 hotfix (Conv20.exe version 2.0.1493.4158) and you plan to upgrade from SMS 2.0 Service Pack 4 (SP4) to SMS 2.0 SP5, Microsoft recommends that you install the 328937 hotfix before you install SMS 2.0 SP5 to avoid the issue that is documented in this article. For additional information about the 328937 hotfix, click the following article number to view the article in the Microsoft Knowledge Base:

328937 SMS: Site Server Processes Management Information Format Files Slowly


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMS200preSP5fix kbfix kbBug KB816968