ExtremeWare Cannot Connect to a Network Load Balanced Dedicated IP Address or a Network Load Balanced Virtual IP Address After Binding NLB (816906)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition

SYMPTOMS

Users may not be able to connect to individual Network Load Balanced nodes from a remote subnet for a while after a new NLB cluster is created.

CAUSE

This behavior occurs because the Extreme Router/Switch is not updating the IP forwarding database.

Before the Network Load Balanced cluster is created, the switch stores the hardware media access control (MAC) address of the individual nodes in its IP forwarding databases. After the Network Load Balanced cluster is created, the MAC address of the nodes changes and the cluster notifies the switch of the change. However, the Extreme switch does not update the IP forwarding database with the new Network Load Balanced virtual MAC address. The switch continues to forward traffic to the incorrect MAC address. This continues until a later switch process updates the old hardware MAC address entry or you manually clear it.

RESOLUTION

To resolve this behavior, update ExtremeWare code to 7.x. To receive updated software for the Extreme Router/Switch, contact the hardware manufacturer.

STATUS

ExtremeWare 4.x and 7.x code updates the IP forwarding database immediately after a new MAC address is received. As a result, these versions do not have this behavior.

WORKAROUND

To work around this behavior, use any of the following methods:
  • Wait for the MAC address to expire in the database and for the correct MAC addresses to replace them. This may take as long as 30 minutes, depending on the switch's default settings.
  • Force an update to the IP forwarding database on ExtremeWare 6.x code. To do so, clear the IP forwarding database. For more information about how to force an update, contact the manufacturer.
  • Restart the Network Load Balanced hosts.

MORE INFORMATION

For more information about Extreme Networks and Extreme switches and routers, visit the following Extreme Networks Web site: The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products. Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Modification Type:MajorLast Reviewed:4/5/2004
Keywords:kbprb KB816906