"LDAP Provider 80070030 Reconnection Failed" Error Message When You Try to Reconnect to Mailbox (816094)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

SYMPTOMS

When you try to reconnect to your Exchange Server mailbox, you may receive the following error message
LDAP Provider

80070030

Reconnection failed.
and the reconnection operation is unsuccessful.

CAUSE

This issue may occur if you use another account to connect to your mailbox and the account name contains Thai characters. The issue occurs because Lightweight Directory Access Protocol (LDAP) queries Active Directory by using the User32 API CharPrevW function, and this function does not recognize some Thai Unicode vowel characters. The User32 API CharPrevW function may not recognize the following Thai Unicode characters:

0E31
0E34
0E35
0E36
0E37
0E38
0E39
0E45
0E47
0E48
0E49
0E4A
E4B
0E4C
0E4D

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time     Version             Size   File name
   -----------------------------------------------------------
   04-Mar-2003  19:12    5.0.2195.6678      42,768  Basesrv.dll
   14-Feb-2003  12:49    5.0.2195.6660     222,992  Gdi32.dll
   14-Feb-2003  12:49    5.0.2195.6656     710,928  Kernel32.dll
   04-Mar-2003  19:12    5.0.2195.6669     333,072  Msgina.dll
   31-Jan-2003  12:51    5.0.2195.6661      90,232  Rdpwd.sys
   04-Mar-2003  19:12    5.0.2195.6680     380,176  User32.dll
   04-Mar-2003  19:12    5.0.2195.6671     385,296  Userenv.dll
   04-Mar-2003  19:08    5.0.2195.6680   1,620,208  Win32k.sys
   03-Mar-2003  09:14    5.0.2195.6675     181,008  Winlogon.exe
   14-Feb-2003  12:49    5.0.2195.6655     243,472  Winsrv.dll
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product


Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbshell kbWin2kSP4fix kberrmsg kbWin2000preSP4Fix kbfix kbbug KB816094