When using sysprep.exe, passwords cannot be saved (815229)



The information in this article applies to:

  • the operating system: Microsoft Windows XP
  • the operating system: Microsoft Windows 2000
  • Microsoft Internet Explorer 6 for Windows
  • Microsoft Internet Explorer 5.5 SP2 for Windows
  • Microsoft Internet Explorer 5.5 SP1 for Windows
  • Microsoft Outlook Express 6 for Windows
  • Microsoft Outlook Express 5.5 for Windows
  • Microsoft Office XP

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When the sysprep tool has been used to install Windows XP or Windows 2000, there are cases in which checking the "Save Password" box in Internet Explorer or Outlook Express does not work. This occurs when the user has logged in as an existing user (such as Administrator) prior to running the sysprep tool.

CAUSE

If you run the sysprep tool, the SID is changed, but the SID change causes the Protected Storage Service to malfunction.

RESOLUTION

To work around this behavior, delete keys beginning with the letter "S" within the following registry:
HKEY_CURRENT_USER\Software\Microsoft\Protected Storage Provider
  • Close Protected Storage Service
  • Run REGEDT32.EXE
  • Choose HKEY_CURRENT_USER\Software\Microsoft\Protected Storage Provider
  • Delete keys beginning with the letter "S"
  • Go to the Security menu, and select Authorize Access
  • Click Add, and add the current user. Choose Full Control for authorized access.
  • Click Delete, and delete the key itself
  • Restart computer

If the above steps are completed prior to running the sysprep tool, users added after the fact will be able to save passwords successfully.

STATUS

This issue has been verified within Microsoft, and is under investigation. When further details are understood, they will be added to this article.

Notice

Since the following functionality also uses Protected Storage Service, they may not work as expected:
-Password save in Internet Explorer
-Auto Complete in Internet Explorer
-Subscription in Internet Explorer

Modification Type:MajorLast Reviewed:9/19/2003
Keywords:kbSecurity kbDeployment kbprb KB815229