Script blocking software prevents installation or use of Visual Studio .NET, Visual Studio 2005, or prerequisites (814731)



The information in this article applies to:

  • Microsoft Visual Studio .NET (2003), Professional Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2003), Academic Edition
  • Microsoft Visual Studio 2005 Professional Edition
  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft .NET Framework 1.1
  • Microsoft .NET Framework 2.0

SYMPTOMS

When you try to use Microsoft Visual Studio .NET or Microsoft Visual Studio 2005 on a computer that has McAfee VirusScan antivirus software enabled, you may notice one or more of the following behaviors:
  • When you try to start Visual Studio .NET or Visual Studio 2005, the development environment may stop responding, and you may receive the following error message:
    An unhandled exception has been caught by the VSW exception filter
    Note This problem occurs regardless of whether Script Blocking is turned on or off for the McAfee antivirus software.
  • When you try to close Visual Studio .NET or Visual Studio 2005, the environment may stop responding.
  • .NET Framework Installation Wizard may stop responding at the end of the setup procedure.

CAUSE

This occurs because an antivirus program or a firewall program is running during the installation of Visual Studio .NET or of Visual Studio 2005. Visual Studio .NET or Visual Studio 2005 Setup has custom actions in VBScript that stop responding or cause problems if you have antivirus script blockers such as those in an antivirus program or a firewall program turned on.

RESOLUTION

McAfee Antivirus HAWK Script Stopper software may cause the behaviors that are listed in the "Symptoms" section. If the McAfee Antivirus HAWK Script Stopper software is enabled, follow these steps to disable it:
  1. Start MacAfee VirusScan, and then click Configure automatic protection settings in the left pane.
  2. Click to clear the Enable HAWK Script Stopper check box, and then click Apply.

STATUS

This behavior is by design.

MORE INFORMATION

Steps to reproduce the behavior

Scenario 1

  1. Install Microsoft Visual Studio .NET or Microsoft Visual Studio 2005.
  2. Install the McAfee antivirus software package, including HAWK Script Stopper.
  3. Start Visual Studio .NET or Visual Studio 2005.
  4. On the File menu, point to New, and then click Project.

Scenario 2

  1. Install Microsoft Visual Studio .NET or Microsoft Visual Studio 2005.
  2. Install the McAfee antivirus software package, including HAWK Script Stopper.
  3. Start Visual Studio .NET or Visual Studio 2005. Visual Studio .NET or Visual Studio 2005 is not set to the default page.

Scenario 3

  1. On a computer that is running Microsoft Windows XP, install the McAfee antivirus software package, including HAWK Script Stopper.
  2. Install Microsoft .NET Framework. Notice that the installation wizard may stop responding at the end of the setup.

REFERENCES

For more information about how to troubleshoot antivirus and firewall issues during installation, click the following article number to view the article in the Microsoft Knowledge Base:

330733 PRB: Visual Studio .NET 2003 Setup may fail when antivirus or firewall program is running

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:3/6/2006
Keywords:kbvs2005applies kbvs2005swept kbSECAntiVirus kbvirus kbprb KB814731 kbAudDeveloper