XADM: Event ID 1105 Logged Repeatedly But Replication Occurs Normally (813928)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

The following event may be repeatedly logged in the Event log: Event ID: 1105
Description: The internal directory replication agent (DRA) Dispatcher thread did not execute. If this message is logged more than 5 times, restart the directory.However, the event may not appear to be related to any problem, and your Exchange server may work as you expect.

CAUSE

This issue may occur when the Replicator async thread check (minutes) registry key is configured incorrectly.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. To resolve this issue, change the default directory replication timeout value in the registry:
  1. Click Start, click Run, type regedt32.exe, and then click OK.
  2. Locate the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeDs\Parameters

  3. Double-click the following registry key: Replicator async thread check (minutes)
  4. Change the values to:

    Data Type: REG_DWORD
    Value: 35 (Dec,default)

  5. Quit Registry Editor.
Note Increase this value in increments of 30 if you receive timeout messages.

Modification Type:MinorLast Reviewed:8/17/2005
Keywords:kbprb KB813928