Clients stop working if a package has many advertisements (813847)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0
  • Microsoft Systems Management Server 2.0 SP1
  • Microsoft Systems Management Server 2.0 SP2
  • Microsoft Systems Management Server 2.0 SP3
  • Microsoft Systems Management Server 2.0 SP4
  • Microsoft Systems Management Server 2.0 SP5

SYMPTOMS

A Systems Management Server (SMS) 2.0 client may stop processing advertisements and may seem to stop responding (hang). When this problem occurs, you experience all the following symptoms:
  • Odpsys32.exe and Odpusr32.exe run constantly but stop logging entries in the Odpsys32.log, Odpusr32.log, and Odpwnt32.log files. You can see these two processes in the task list by running the Windows Task Manager tool. Typically, these processes remain in the task list for only a couple seconds.
  • Smsmon32.exe stops logging entries in the Smsmon32.log file and seems to stop responding (hang).
  • The Smsapm32.log file contains the following log entries. There is a 30-minute delay between these two log entries:

    SCHED DATA : Waiting on ODP_DONE event.
    SCHED DATA : Event timed-out. Caution!! Some of the advertisements scheduled to run at logon, may not run.

This problem occurs only on SMS clients that are running Microsoft Windows NT 4.0 or Microsoft Windows 2000.

Note that other programs could be affected when an SMS client is in this state. For example, IBM Personal Communications WorkStation Program Version 5.5 for Windows may fail to start until Smsmon32.exe either starts responding again or is stopped.

CAUSE

This problem may occur if you advertise to a client many SMS advertisements for the same SMS package. The problem is caused by the limited size of an interprocess communication (IPC) pipe that is used to communicate by the Offer Data Providers (ODPs) and the SMS Available Program Manager (Smsapm32.exe) component. The specific number of advertisements that cause the problem to occur depends on the size of the data that you enter in the package and advertisements fields in the SMS Administrator console. For example, if the advertisements have long names, it takes fewer advertisements to cause the problem. The problem typically occurs if you have from 15 to 30 advertisements for the same package.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

SMS 2.0 Service Pack 4


The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name            Platform
   ---------------------------------------------------------------------------
   01-May-2002  22:15  2.0.92.9         392,174  Apasetup.exe         x86
   01-May-2002  18:55  2.0.1493.4163    182,096  Ccim32.dll           x86
   01-May-2002  22:15  2.0.92.9       1,324,794  Ccmcore.exe          x86
   01-May-2002  22:15  2.0.1493.4202  1,238,944  Clibase.dll          x86
   01-May-2002  22:15  2.0.1493.4202  3,409,755  Clicore.exe          x86
   01-May-2002  13:05  2.0.1493.4105     88,432  Clisvcl.exe          x86
   01-May-2002  22:15  2.0.1493.4202      8,512  Cliver.exe           x86
   01-May-2002  22:15                        67  Compverbase.ini      x86
   01-May-2002  22:15                        67  Compversmsapm32.ini  x86
   01-May-2002  22:15                        67  Compverswdist.ini    x86
   01-May-2002  16:45  2.0.1493.4149     34,656  Cqmgr32.dll          x86
   01-May-2002  22:15  2.0.1493.4202     54,640  Odpsys32.exe         x86
   01-May-2002  22:15  2.0.1493.4202     60,784  Odpusr32.exe         x86
   01-May-2002  22:15  2.0.1493.4202     63,344  Odpwin9x.exe         x86
   01-May-2002  22:15  2.0.1493.4202    254,320  Smsapm32.exe         x86
   01-May-2002  22:15  2.0.92.9         640,938  Swdist32.exe         x86

SMS 2.0 Service Pack 5


The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version              Size  File name           Platform
   ---------------------------------------------------------------------------
   29-Jul-2003  11:56  2.0.1493.5140     238,944  Abnwcli.dll         x86
   29-Jul-2003  11:56  2.0.92.10         383,468  Apasetup.exe        x86 
   29-Jul-2003  11:56  2.0.1493.5140     263,008  Bindclin.dll        x86
   29-Jul-2003  11:56  2.0.92.10       1,377,457  Ccmcore.exe         x86
   29-Jul-2003  11:56  2.0.1493.5147   1,251,744  Clibase.dll         x86
   29-Jul-2003  11:56  2.0.1493.5147   3,497,214  Clicore.exe         x86
   29-Jul-2003  11:56  2.0.1493.5144      90,480  Clisvcl.exe         x86
   29-Jul-2003  11:56  2.0.1493.5147       8,512  Cliver.exe          x86
   29-Jul-2003  11:56                         67  Compverbase.ini     x86
   29-Jul-2003  11:56                         67  Compversmsapm32.ini x86
   29-Jul-2003  11:56                         67  Compverswdist.ini   x86
   29-Jul-2003  11:56  2.0.1493.5136      35,168  Cqmgr32.dll         x86
   29-Jul-2003  11:56  2.0.1493.5140     161,120  Falclin.dll         x86
   29-Jul-2003  11:56  2.0.1493.5140     340,832  Mslmclin.dll        x86
   29-Jul-2003  11:56  2.0.1493.5140     272,736  Ndsclin.dll         x86
   29-Jul-2003  11:56  2.0.1493.5147      54,640  Odpsys32.exe        x86
   29-Jul-2003  11:56  2.0.1493.5147      60,784  Odpusr32.exe        x86
   29-Jul-2003  11:56  2.0.1493.5147      63,344  Odpwin9x.exe        x86
   29-Jul-2003  11:56  2.0.1493.5147     257,904  Smsapm32.exe        x86
   29-Jul-2003  11:56  2.0.92.10         641,211  Swdist32.exe        x86
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

How to Install the Hotfix

Using the Hotfix Installer

Note This method is for only Intel-based computers.
  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the Sms2.0-kb813847-spX-x86-enu.exe update file (where X is the service pack version) and the platform folders to the new folder. The folder structure must be such that the update file is located one folder "above" the platform folders.
  3. From each of the primary and secondary SMS site servers in your environment, log on to your site server by using an account with administrator permissions.
  4. Quit the SMS Administrator console if it is running.
  5. Run Sms2.0-kb813847-spX-x86-enu.exe, and then follow the instructions in the wizard.

Performing a Manual Installation

  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the platform folders that contain the hotfix files to the folder that you created in step 1.
  3. From each of the primary and secondary SMS site servers in your environment, log on to your site server by using an account with administrator permissions.
  4. Quit the SMS Administrator console if it is running.
  5. Stop all the SMS services.
  6. Replace the following files in the SmsRootFolder\Bin\Platform folder with the versions from the hotfix:
    • Ccim32.dll
    • Clisvcl.exe
    • Cqmgr32.dll
    • Odpsys32.exe
    • Odpusr32.exe
    • Smsapm32.exe
  7. Replace the Swdist32.exe file in the SmsRootFolder\Inboxes\Clicomp.src\SWDist\Platform folder with the version from the hotfix.
  8. Replace the Apasetup.exe file in the SmsRootFolder\Inboxes\Clicomp.src\Smsapm32\Platform folder with the version from the hotfix.
  9. Replace the Ccmcore.exe and Clicore.exe files in the SmsRootFolder\Inboxes\Clicomp.src\Base\Platform folder with the versions from the hotfix.
  10. Replace the Compver.ini file in the SmsRootFolder\Inboxes\Clicomp.src\SWDist folder with the Compverswdist.ini file from the hotfix. Note that you must rename the Compverswdist.ini file to Compver.ini.
  11. Replace the Compver.ini file in the SmsRootFolder\Inboxes\Clicomp.src\Smsapm32 folder with the Compversmsapm32.ini file from the hotfix. Note that you must rename the Compversmsapm32.ini file to Compver.ini.
  12. Replace the Compver.ini file in the SmsRootFolder\Inboxes\Clicomp.src\Base folder with the Compverbase.ini file from the hotfix. Note that you must rename the Compverbase.ini file to Compver.ini.
  13. Restart the SMS services

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

WORKAROUND

To work around this problem, avoid offering many active advertisements for the same package to an SMS client.

MORE INFORMATION

Important After you install this fix on an SMS 2.0 SP4 site server, make sure you do not use program icons that are larger than 8192 bytes. These program icons can cause the SMS client and applications on client computers to become unresponsive.

The problem that this article describes is caused by an operating system limitation in Windows NT 4.0 and Windows 2000. The problem may still occur after you install the hotfix that this article describes. However, after you install the hotfix, 4 times as much data can be transferred between the ODPs and Smsapm32.exe. For example, if the problem previously occurred with 15 advertisements for the same package, you can create approximately 60 advertisements for the same package after you install the hotfix.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMS200preSP6fix kbfix kbBug KB813847