You cannot open any folders under a WebDAV virtual directory that is configured to point to a root drive in IIS 5.0 (813843)



The information in this article applies to:

  • Microsoft Internet Information Services 5.0

SYMPTOMS

When you use Microsoft Internet Explorer to access a Web Distributed Authoring and Versioning (WebDAV) virtual directory that is configured to point to the root of a drive such as drive C, you cannot open any of the folders or subfolders under the root drive as a Web folder. Additionally, you receive an error message that is similar to the following:
The folder http://ServerName/FolderName/ is no longer available.

CAUSE

This problem occurs because WebDAV prepends the folder names with the virtual directory name in the Uniform Resource Identifier (URI).

For example, if you name the virtual directory "Dav" and configure the virtual directory to point to drive C, and then you use Internet Explorer to open the virtual directory, you see all the folders under drive C.

If you double-click any folder (for example, "MyFolder") under the virtual directory, the folder that you are trying to open may be prepended with the virtual directory name in the URI. For example, the "MyFolder" folder may appear as "DavMyFolder." Because a folder that is named "DavMyFolder" exists under the virtual directory, you receive the message that is mentioned in the "Symptoms" section.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to obtain the latest Windows 2000 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 Service Pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   24-Feb-2003  04:31  5.0.2195.6668     246,032  Httpext.dll    

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was corrected in Microsoft Windows 2000 Service Pack 4.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbtshoot kbfix kbBug kbQFE KB813843 kbAudEndUser kbAudITPRO