"General Access Denied" Error Message When Client Application Tries to Create a Channel (813210)



The information in this article applies to:

  • Microsoft BizTalk Server 2002
  • Microsoft BizTalk Server 2000
  • Microsoft BizTalk Server 2000 SP1
  • Microsoft BizTalk Server 2000 SP2

SYMPTOMS

If a BizTalk application integration component (AIC) is set up as a COM+ server application that is running under a specific identity, some client applications may receive a "General Access Denied" error message while calling the Create method of the IBizTalkChannel interface to create a channel with this AIC involved

CAUSE

This issue occurs if the account that is running the client application is different from the COM+ identity account of the AIC.

RESOLUTION

To work around this issue, use either of the following methods:
  • Use the same account as the COM+ identity account of the AIC to run the client application. You can set the COM+ identity of the AIC to Interactive.
  • Use Dcomcnfg.exe to add the COM+ identity account of the AIC to the Default Access Permissions list of Distributed Component Object Model (DCOM).

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:6/4/2003
Keywords:kberrmsg kbprb KB813210