FIX: Delays Occur When You Send Messages to a Message Queuing Server (813035)



The information in this article applies to:

  • Microsoft Message Queuing 2.0

SYMPTOMS

When you send messages to a Microsoft Message Queuing (also known as MSMQ) server, you may experience delays if the server's connection to its domain controller is not available or is slow.

CAUSE

When you send a message to a Message Queuing server, the server must check the access control list (ACL) for the queue to see if the user who sent the message has permissions to write to this queue. If the domain controller is not available or is responding slowly, this validation process may take significant time. Message Queuing does not accept the message until the validation is complete, causing delays when you send messages.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   15-Jan-2003  14:01  5.0.0.759         280,336  Mq1repl.dll      
   21-Oct-2002  17:31  5.0.0.759          14,096  Mq1sync.exe      
   19-Dec-2002  18:37  5.0.0.764          75,408  Mqac.sys
   15-Jan-2003  14:01  5.0.0.760         217,360  Mqads.dll        
   30-Oct-2002  13:43  5.0.0.761          25,360  Mqbkup.exe       
   15-Jan-2003  14:01  5.0.0.750          76,560  Mqdscli.dll      
   15-Jan-2003  14:01  5.0.0.735          41,744  Mqdssrv.dll      
   21-Oct-2002  17:31  5.0.0.759          98,064  Mqmig.exe        
   15-Jan-2003  14:01  5.0.0.759         265,488  Mqmigrat.dll     
   15-Jan-2003  14:01  5.0.0.740         222,480  Mqoa.dll         
   15-Jan-2003  14:01  5.0.0.762           8,464  Mqperf.dll       
   15-Jan-2003  14:01  5.0.0.765         425,232  Mqqm.dll         
   15-Jan-2003  14:01  5.0.0.765         102,672  Mqrt.dll         
   15-Jan-2003  14:01  5.0.0.759          70,928  Mqsec.dll        
   15-Jan-2003  14:01  5.0.0.762          23,824  Mqupgrd.dll      
   15-Jan-2003  14:01  5.0.0.763         110,352  Mqutil.dll       
   15-Jan-2003  14:01  5.0.0.748          64,784  Msmq.cpl 


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.
This problem was first corrected in Windows 2000 Service Pack 4.

MORE INFORMATION

By default, Message Queuing grants Send permissions to the Everyone group on all newly created queues. As a result, this problem may or may not show up, depending on where the access control entry (ACE) for the Everyone Send permission appears in the queue's ACL. If this ACE is at the top of the ACL, Message Queuing sees it immediately and accepts the message without delay. If the ACE is farther down in the ACL, Message Queuing connects to the domain controller to check the ACEs farther up in the ACL before it reaches the Everyone Send ACE. This delays the acceptance of the message when the domain controller is slow or is not available. The order of ACEs in the ACL is random and does not necessarily correspond to how they are listed on the Security tab of the queue's property sheet.

This hotfix resolves this problem by requiring Message Queuing to check the whole ACL for an Everyone Send ACE first. If Message Queuing finds this ACE, it accepts the message immediately without trying to communicate with the domain controller at all. If Message Queuing does not find this ACE, it connects to the domain controller to check all the ACEs.
To identify this problem, follow these steps:
  1. Create a registry file (.reg) that contains the following information:
    Windows Registry Editor Version 5.00
    		[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters\Debug]
    		"LoggingTypes"=dword:c0000000
  2. Save the .reg file to disk, and then in Windows Explorer, double-click the .reg file to import this information into the registry.
  3. In Control Panel, double-click Administrative Tools, and then double-click Services to open the Services applet.
  4. Right-click the Message Queuing service, and then click Restart.

    A file named Msmq.log is created in the %WINDIR%\Debug directory.
  5. Review this Msmq.log file when you start experiencing delays, and locate the following entry:QM Error: usermap/143, Point If this entry is listed in the file, you are experiencing the problem that is described in this article. To resolve the problem, apply the hotfix.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbfix KB813035 kbAudDeveloper