XADM: Public Contacts Folder Takes a Long Time to Open (812225)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

Exchange:208149

SYMPTOMS

When you open a public contacts folder that contains a large number of items, the folder takes a long time to open.

CAUSE

This problem may occur if the Microsoft Windows 2000 Access Control List (ACL) has been modified for "per item" restrictions.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

When a client opens a public contacts folder, the server builds a view to reflect the client's search criteria, and then if possible, this view is cached on the server. If "per item" ACLs are applied to items in the public contacts folder, the server builds a new view that reflects the ACL changes when the client opens the folder. ACLs are used to hide items from a client. When the ACLs are changed, the server rebuilds the view to make sure that each item is still visible to the client and fits the client's search criteria.

Modification Type:MinorLast Reviewed:6/13/2003
Keywords:kbBug kbprb KB812225 kbAudITPRO