FIX: All cluster members may be suspended after the Application Center load balancing COM+ application is stopped (811675)



The information in this article applies to:

  • Microsoft Application Center 2000
  • Microsoft Application Center 2000 SP1

SYMPTOMS

When you stop the Application Center load balancing COM+ application on a COM+ application server, and component load balancing (CLB) polling restarts the application, all members in the Application Center 2000 COM+ cluster may enter a suspended state. The cluster controller is not affected and remains online.

CAUSE

This problem may occur if the COM+ load balancing service does not set the tracker object status correctly when the load balancing service starts.

RESOLUTION

In this hotfix, the COM+ load balancing service has been modified so that the server status is set from the metabase when the load balancing service starts.

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Application Center 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The Microsoft Application Center 2000 version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
    Date        Time   Version             Size   File name
   ------------------------------------------------------------
   19-Dec-2002  00:31  1.0.441.15        356,064  Accluster.exe    
   19-Dec-2002  00:28  1.0.441.15         51,376  Comlb.exe 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbQFE kbfix KB811675 kbAudDeveloper