Program May Stop Working If It Uses RPC with a UNIX Server (811576)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

A client program that uses Remote Procedure Call (RPC) and is running on Microsoft Windows XP may randomly experience access violations when the program is communicating with an RPC server that is running on a UNIX server.

CAUSE

This problem is caused by an incorrect buffer in the RPC run-time DLL (Rpcrt4.dll). The buffer overrun occurs only if a client makes an outgoing RPC call to a UNIX server after the client has been idle for between 40 and 60 seconds, and if the RPC call expects a large response. The overrun buffer corrupts the memory block that follows the buffer that is used by RPC, and may cause random access violations in the client program.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   23-Dec-2002  09:31  5.1.2600.1154  505,856  Rpcrt4.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

Some RPC servers may request that a client program end its idle connections to reduce resource usage. This is done by sending a shutdown Protocol Data Unit (PDU) to the client. On the client, RPC checks its receive buffer only when it is making an outgoing call to the RPC server. Some UNIX servers send shutdown PDUs after every 20 seconds of idle time. If the client is idle long enough for the server to send 2 consecutive shutdown PDUs, RPC on the client coalesces the PDUs in its receive buffer. If the client decides to make an outgoing call at this time, it tries to process the two coalesced PDUs in its receive buffer first. During processing, the coalescing causes the receive buffer to be reallocated. However, buffer-size information is not tracked correctly. This can result in a buffer that is reported to be larger than it really is. The outgoing call is then made. If the response is larger than the real (not the reported) size of the reallocated receive buffer, an access violation occurs.

If the client is idle long enough for the server to send three shutdown PDUs, RPC closes the connection. A new connection is then created to run the outgoing call. In this case, the problem does not occur. Therefore, the problem is likely to occur after the client program is idle for more than 40 seconds, but less than 60 seconds. However, this depends on how long the UNIX server waits before sending a shutdown PDU.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbenv kberrmsg kbQFE kbWinXPpreSP2fix kbfix kbbug KB811576 kbAudDeveloper kbAudITPRO