A "Stop 0x0000001E" Error Occurs in Win32k.sys in Windows 2000 (811363)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1

SYMPTOMS

You may receive the following error message on a blue screen when Windows 2000 is working on a graphics operation:
Stop 0x0000001E (0xC0000005, 0xA0023BE5, 0x00000000, 0x0000004C)

CAUSE

There is an error in third-party code that calls the Graphics Device Interface (GDI) with incorrect parameters. This fix is designed only to prevent the problem in the third-party code from causing a kernel failure error in Windows 2000. Depending on the function of the third-party driver, unexpected results might occur from graphics operations.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   06-Feb-2003  08:23  5.0.2195.6621     42,256  Basesrv.dll 
   06-Feb-2003  08:22  5.0.2195.6660    222,992  Gdi32.dll   
   06-Feb-2003  08:22  5.0.2195.6656    710,928  Kernel32.dll
   06-Feb-2003  08:23  5.0.2195.6662    333,072  Msgina.dll
   31-Jan-2003  12:51  5.0.2195.6661     90,232  Rdpwd.sys
   06-Feb-2003  08:23  5.0.2195.6655    379,664  User32.dll
   06-Feb-2003  08:23  5.0.2195.6620    388,368  Userenv.dll
   06-Feb-2003  08:21  5.0.2195.6663  1,620,144  Win32k.sys
   16-Dec-2002  14:25  5.0.2195.6623    179,984  Winlogon.exe
   06-Feb-2003  08:23  5.0.2195.6655    243,472  Winsrv.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product


Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbOSWin2000fix kbWin2kSP4fix kbWin2000preSP4Fix kbfix kbbug kbprb KB811363