In Exchange 2000 Server, you cannot recover deleted items from or modify the contents of public folders through Microsoft Outlook (811358)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange 2000 Enterprise Server

SYMPTOMS

You cannot use Outlook to recover deleted items from a public folder or modify the contents of a public folder on Microsoft Exchange 2000 Server. You experience the following behaviors:
  • An event similar to the following is logged in the Application log of Event Viewer:Event ID: 1235
    Event Type: Warning
    Event Source: MSExchangeIS Public Store
    Event Category: Access Control
    Description:
    User failed an operation on folder on database "First Storage Group\Public Folder Store (Server)" because the user did not have the following access rights: 'Delete' 'Read Property' 'Write Property' 'Create Message' 'View Item' 'CreateSubfolder' 'Write Security Descriptor' 'Write Owner' 'Read Security Descriptor' 'Contact'
  • You receive the following error message when you try to recover deleted items from a public folder:
    Outlook was unable to recover some or all of the items in this folder. Make sure you have the required permissions to recover items in this folder and try again. If the problem persists contact your administrator.

CAUSE

This behavior may occur if either of the following conditions is true:
  • The public folder that you want to restore is set to allow only certain custom forms.
  • You do not have the appropriate permissions to access the public folder hierarchy.

RESOLUTION

The public folder is set to allow only certain custom forms
To resolve this behavior, follow these steps:
  1. Log on to an Outlook client computer as a user who has owner permissions for the public folder.
  2. Right-click the folder that you want to restore, and then click Properties.
  3. Click the Forms tab.
  4. In the Allow these forms in this folder section, click Any form, and then click OK.
You do not have the appropriate permissions to access the public folder hierarchy
To troubleshoot and resolve this behavior, make sure that appropriate permissions are configured for the public folder hierarchy, temporarily grant the Everyone group Full Control permissions, recover the deleted items from the public folders, and then restore the default permissions for the Everyone group. To do so, follow these steps:
  1. Make sure that the appropriate permissions are configured for the public folder hierarchy:
    1. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
    2. Expand Folders, right-click Public Folders, and then click Properties.
    3. Click the Security tab.
    4. Verify that the appropriate permissions are configured for the folder. The following is a list of the default permissions for the public folder hierarchy:
      • Administrator: Full control
      • Domain Admins: All permissions except the following:

        Full control
        Delete children
        Delete tree

      • Enterprise Admins: Full control
      • Everyone:

        Create public folder
        Create top level public folder
        Create named properties in the information store

        Note By default, the Everyone group does not have Full Control permissions.
      • Exchange Domain Servers: All permissions except the following:

        Full control
        Write
        Delete
        Change permissions
        Take ownership
        Delete children
        Add/remove self
        Write properties
        Delete tree
        List object

      • Exchange Services: Full control
  2. Temporarily grant Full Control permissions to the Everyone group for the Public Folders folder:
    1. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
    2. Expand Folders, right-click Public Folders, and then click Properties.
    3. Click the Security tab.
    4. In the Name box, click the Everyone group. Note that by default, the Everyone group is granted the following permissions:

      Create public folder
      Create top level public folder
      Create named properties in the information store

    5. In the Permissions box, select the Allow check box next to the Full Control permission, and then click OK.
    6. Quit Exchange System Manager.
  3. Force Active Directory replication over all connections between domain controllers:
    1. Click Start, point to Programs, point to Administrative Tools, and then click Active Directory Sites and Services.
    2. Expand Sites, expand Default-First-Site-Name, expand Servers, expand ServerName, and then click NTDS Settings.
    3. In the right pane, right-click each connection that is listed, and then click Replicate Now.
    4. Quit the Active Directory Sites and Services snap-in.
  4. Start Outlook, and then recover the deleted items that you want from the public folders.
  5. Restore the default permissions for the Everyone group for the Public Folders folder:
    1. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
    2. Expand Folders, right-click Public Folders, and then click Properties.
    3. Click the Security tab.
    4. In the Name box, click the Everyone group.
    5. In the Permissions box, clear the Allow check box next to the Full Control permission, and then click OK.
    6. Quit Exchange System Manager.

MORE INFORMATION

For more information about how to troubleshoot a similar issue, click the following article number to view the article in the Microsoft Knowledge Base:

313866 You cannot create a new public folder in Exchange 2000 Server or in Exchange Server 2003


Modification Type:MajorLast Reviewed:3/27/2006
Keywords:KB811358