"Links 2003 has encountered a problem and needs to close" error message appears when you start the game (810743)



The information in this article applies to:

  • Microsoft Links 2003, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Links 2003 Championship Edition

SYMPTOMS

When you start Microsoft Links 2003, you may receive the following error message:
Links 2003 has encountered a problem and needs to close. We are sorry for the inconvenience.
When you click click here on the error message to view the data in the error report, error signature information similar to the following appears, where xxxxxxxx is a string of alphanumeric characters:
Error Signature
AppName          AppVer      ModName     ModVer          Offset  
    linksmmiii.exe   22.7.8.241  ntdll.dll   5.1.2600.1106   xxxxxxxx

CAUSE

This behavior may occur if you start Links after you use a non-administrator user account to log on to your computer. For example, this may occur if you log on to your Microsoft Windows XP Professional-based computer with an account that is a member of the Users group, or if you log on to your Microsoft Windows XP Home Edition-based computer by using a Limited user account.

RESOLUTION

To resolve this behavior, use one of the following methods (as appropriate to your situation):

Method 1: Use the Run As command to run links with administrator credentials

To use the run as command to run Links with administrator credentials, follow these steps:
  1. Click Start, point to All Programs, point to Microsoft Games, point to Links 2003, right-click Links 2003, and then click Properties.
  2. Click the Shortcut tab (if it is not already selected), and then click Advanced.
  3. Click to select the Run with different credentials check box, click OK, and then click OK again.
  4. Start Links.
  5. In the Run As dialog box that appears, click The following user, type the name of a user account that has administrative credentials and the password in the User name and Password boxes, and then click OK.

Method 2: Grant the user account appropriate credentials

To do this, use the following method that is for your version of Windows XP:

Windows XP Professional

If you are running Windows XP Professional, add the user account to the Power Users group. To do so, follow these steps:
  1. Log on to the computer as Administrator.
  2. Click Start, and then click Control Panel.
  3. Double-click User Accounts.
  4. Click Change an account.
  5. Click the account that you want to change.
  6. Click Change the account type, click Computer administrator, and then click Change Account Type.
  7. Close the User Accounts window, and then quit Control Panel.

Windows XP Home Edition

If you are running Windows XP Home Edition, change the user account type to Computer Administrator. To do so, follow these steps:
  1. Log on to the computer as Administrator.
  2. Click Start, and then click Control Panel.
  3. Click Performance and Maintenance, and then click Administrative Tools.
  4. Double-click Computer Management.
  5. In the left pane, expand Local Users and Groups, and then expand Groups.
  6. In the right pane, double-click Power Users, and then click Add.
  7. In the Select Users dialog box, type the name of the user account that you want to add, and then click OK.
  8. Click OK, quit Computer Management, and then close the Administrative Tools window.

MORE INFORMATION

For additional information about how to run programs in Windows XP when you log on using a Limited User account, click the following article number to view the article in the Microsoft Knowledge Base:

307091 Certain programs do not work correctly if you log on using a Limited User Account


Modification Type:MinorLast Reviewed:1/9/2006
Keywords:kbConfig kberrmsg KB810743