Some characters from End User Defined Character (EUDC) fonts do not appear correctly in Windows XP (332134)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q332134

SYMPTOMS

Some characters from End User Defined Character (EUDC) fonts may not appear correctly in Microsoft Windows XP. Characters from various other fonts that have code points in the Private Use Area (PUA) may appear instead of the EUDC font characters that you expect.

Fujitsu Japan first reported this problem. Fujitsu noted that some characters that have PUA code point assignments in some of the Windows XP core Latin fonts were displayed instead of the EUDC font characters. Additionally, some characters that have PUA code point assignments in some of the Windows XP default East Asian fonts were displayed instead of the EUDC font characters.

Note This problem is not specific to a particular language, locale, or EUDC font. This problem might occur with any language or locale when you use characters that you have defined in an EUDC font.

CAUSE

This problem occurs because many Latin fonts and some East Asian fonts that are included with Microsoft Office programs and with Windows contain characters that are mapped to the PUA. An Office program accesses a sequence of these fonts when a character is not contained in the current font before that Office program accesses EUDC fonts. Additionally, Windows currently accesses fonts in the operating system font-link chains before Windows accesses EUDC fonts.

Therefore, if any one or more of the following conditions are true, the character from the current font, the character from the Office program's font, or the character from the font in the operating system font-link chain is accessed first and then displayed:
  • The current font has a character that is mapped to the PUA at the same code point as a character in your EUDC font.
  • A font that an Office program accesses has a character that is mapped to the PUA at the same code point as a character in your EUDC font.
  • A font in the operating system font-link chain has a character that is mapped to the PUA at the same code point as a character in your EUDC font.

RESOLUTION

Install the hotfix that is mentioned in the "Hotfix information" section. This hotfix works with the following operating systems:
  • Windows XP
  • Windows XP Service Pack 1 (SP1)
  • Windows XP Service Pack 2 (SP2)
Note Windows XP Service Pack 2 (SP2) contains updates to reduce the chance that you will experience this problem. Typically, Windows XP SP2 resolves this problem for all scenarios. However, if you have fully-populated EUDC fonts, you might still experience this problem after you install Windows XP SP2. To reduce the chance that you will experience this problem of EUDC fonts, please install the latest hotfix for Windows XP SP2.

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version          Size        File name   Platform
   ---------------------------------------------------------------------
   09-Jul-2003  17:26                    1,442,962  Intl.inf    IA-64
   09-Jul-2003  17:39                   10,512,288  Simsun.ttc  IA-64
   07-Jul-2003  12:50         5.3.18.5       6,144  Spmsg.dll   IA-64
   10-Jul-2003  10:59  1.411.2600.1221     774,144  Usp10.dll   IA-64
   11-May-2003  21:00  1.411.2600.1221     351,232  Wusp10.dll  IA-64
   09-Jul-2003  17:27                      806,578  Intl.inf    x86
   09-Jul-2003  17:39                   10,512,288  Simsun.ttc  x86
   07-Jul-2003  12:50         5.3.18.5       6,656  Spmsg.dll   x86
   10-Jul-2003  10:59  1.411.2600.1221     351,232  Usp10.dll   x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:8/7/2006
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbprb kbbug kbfix kbWinXPpreSP2fix KB332134 kbAudITPRO