Must Restart the Interchange COM+ Application After a Connection Loss to SQL (331337)



The information in this article applies to:

  • Microsoft BizTalk Server 2002

This article was previously published under Q331337

SYMPTOMS

After a connection interruption between the computer that is running BizTalk Server and the computer that is running Microsoft SQL Server, you may receive the following error message when you call IInterchange::Submit():
An error occurred in BizTalk Server.

Details: ------------------------------

The following stored procedure call failed: " { call adm_cache_loadTimeStamp( ?, ?, ?, ?, ?, ?)}". :'[DBNETLIB][ConnectionWrite (send()).]General network error. Check your network documentation.' Unspecified error

The configuration data from the database could not be reloaded.

There was a failure creating the internal work item. Make sure that SQL Server is running.

CAUSE

The Interchange application caches its connection information until it is restarted or a failure occurs.

RESOLUTION

To resolve this issue, identify and correct the cause of the connection interruption.

WORKAROUND

To work around this issue, you may be able to build error routines to trap this error and resubmit the initial failed submission, depending on your submission method. Only the initial submission after the connection interruption will fail, and then the connection will be re-established.

STATUS

This issue is by design.

Modification Type:MajorLast Reviewed:12/19/2002
Keywords:kbprb KB331337