"Unable to Establish a Connection with Active Directory" error message when you use the Message Queuing snap-in to browse messages in a public queue (330480)



The information in this article applies to:

  • Microsoft Message Queuing 2.0

This article was previously published under Q330480

SYMPTOMS

When you use the Microsoft Message Queuing MMC snap-in to browse messages in a public queue after you successfully install Message Queuing, you may receive the following error message:
Cannot read messages. Error: Unable to establish a connection with Active Directory. Verify there are sufficient permissions to perform this operation.
You cannot reinstall Message Queuing, because Message Queuing setup cannot locate the Message Queuing servers on the network.

CAUSE

This issue occurs if User Datagram Protocol (UDP) port 1801 is closed on the firewall after you install Message Queuing. UDP port 1801 is used for server discovery during Setup, and it is also used to discover new servers when previously known Message Queuing servers cannot be contacted. The client computer cannot discover a Message Queuing server that is across a firewall if UDP port 1801 is closed.

NOTE: You cannot reinstall Message Queuing, because MSMQ Setup cannot locate the Message Queuing servers on the network.

RESOLUTION

To resolve this problem, open UDP port 1801.

STATUS

This behavior is by design.

MORE INFORMATION

To detect server discovery failure that occurs after UDP port 1801 is closed, analyze a network trace. If Internet Control Message Protocol (ICMP) Destination Unreachable packets occur in the trace with a Port Unreachable return code, either the port is not open on the firewall or the server is filtering out TCP/IP traffic on port 1801.

Setup typically fails if the server discovery process fails. Therefore, you cannot browse the public queue.

Modification Type:MajorLast Reviewed:4/19/2005
Keywords:kbprb KB330480 kbAudDeveloper