Hewlett Packard PhotoSmart 1000 Series Printer Does Not Work with Printer Port Problems (330178)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

This article was previously published under Q330178

SYMPTOMS

You may experience either of the following symptoms that are related to your Hewlett Packard PhotoSmart 1000 series printer:
  • When you try to install your Hewlett Packard PhotoSmart 1000 series printer, the installation process may not complete, and you may receive the following error message:
    Error 09: unable to create directory c:\program files\hpphotosmart\printer
  • After you upgrade to Windows XP, your Hewlett Packard PhotoSmart 1000 series printer may not work.

CAUSE

This issue may occur if your printer port settings are configured incorrectly.

RESOLUTION

To resolve this issue:
  1. Right-click My Computer, and then click Manage.
  2. Expand System Tools, and then double-click Device Manager.
  3. Double-click Ports (COM & LPT), and then determine if the LTP printer port is listed as "ECP Printer Port". If it is, go to step 4, and do not complete the rest of step 3. If it is not, change the setting for this port to ECP in your computer BIOS. For information about how to do so, see the documentation that was included with your computer or your mainboard.
  4. Double-click ECP Printer Port (LPT), and then click the Port Settings tab.
  5. Click Use any interrupt assigned to the port, click to select the Enable legacy Plug and Play detection check box, and then click OK.
  6. Restart your computer.

MORE INFORMATION

For additional information about Hewlett Packard PhotoSmart 1000 series printers, visit the following Hewlett Packard Web sites:Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Modification Type:MinorLast Reviewed:4/29/2003
Keywords:kbprint kbHardware kbprb KB330178