E-Mail Messages Sent to a Secondary Recipient Are Delivered Two Times (329043)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q329043

SYMPTOMS

A secondary SMTP mail recipient may receive duplicate e-mail messages in a mixed Microsoft Exchange Server organization.

CAUSE

This problem may occur if the following conditions are true:
  • The Microsoft Exchange Server 5.5 server and Exchange 2000 Server are in seperate routing groups.
  • The destination of the mailbox is on the Exchange Server 5.5 server.
  • The entry point for the e-mail message is on the Exchange 2000 Server gateway.
  • The destination mailbox is set to deliver to a different recipient that is an SMTP e-mail address, and the mailbox is set to deliver to the Exchange Server 5.5 server mailbox.
  • The Active Directory Connector (ADC) replicates the "alt-recipient" attribute from the Exchange Server 5.5 server folder to Active Directory.
In Exchange 2000 Server, the categorizer handles the secondary recipient immediately instead of waiting until it reaches the destination mailbox server. In this situation, the SMTP e-mail enters the Exchange Server organization through a gateway on Exchange 2000 Server. The categorizor checks the recipient against Active Directory and notes that the recipient has a forwarding address. Exchange 2000 Server then bifurcates the message; Exchange 2000 Server forwards one e-mail message to the secondary recipient and forwards the other e-mail message to the destination mailbox. When the Exchange Server 5.5 server receives the message, the Exchange Server 5.5 server also checks the recipient against the directory and notices that it has the recipient attribute of the secondary recipient. Finally, the Exchange Server 5.5 server forwards the message to the secondary recipient, creates the second message, and then delivers it to the Exchange 2000 Server destination mailbox.

RESOLUTION

Configure the ADC to not replicate the "alt-recipient" attribute from the Exchange Server 5.5 server folder to Active Directory:
  1. Start the Active Directory Connector Management tool.
  2. In the left pane, right-click Active Directory Connector Management, and then view the properties.
  3. Click the From Exchange tab.
  4. Click to clear the alt-recipient check box.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

MORE INFORMATION

For additional information about this problem, click the following article number to view the article in the Microsoft Knowledge Base:

269408 XADM: Duplicate E-Mail in Exchange 2000


Modification Type:MinorLast Reviewed:6/13/2003
Keywords:kbemail kbprb kbbug KB329043