Cannot Reconnect to Remote Desktop After a Disconnection During Windows XP Service Pack 1 Installation (328930)



The information in this article applies to:

  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1

This article was previously published under Q328930

SYMPTOMS

You may experience a problem when you try to install Windows XP Service Pack 1 (SP1) on a remote computer by using the Remote Desktop feature. If you are disconnected from the remote computer during the installation, you may be unable to reconnect to the remote computer. After this occurs, you may experience one or more of the following symptoms:
  • You may not be able to restart the remote computer and complete the installation of Windows XP SP1.
  • When you type your user name and password to reconnect to the remote computer, you are immediately disconnected, and you may receive one or both of the following error messages:
    Remote Desktop Disconnected
    The Remote connection has timed out. Please try connecting to the remote computer again.
    Remote Desktop Disconnected
    The client could not establish a connection to the remote computer.

    The most likely causes for this error are:
    1) Remote connections might not be enabled at the remote computer.
    2) The maximum number of connections was exceeded at the remote computer.
    3) A network error occurred while establishing the connection.
  • When you log on to the remote computer locally, you may receive one or more instances of the following error message:
    csrss.exe - Unable To Locate Component

    This application has failed to start because winsrv was not found. Re-installing the application may fix this problem.

CAUSE

This problem occurs because Windows XP SP1 installs a new version of the Microsoft Windows NT Logon tool (Winlogon.exe). The new version of Winlogon.exe is dependent upon other DLL files that are upgraded by Windows XP SP1. The new version of Winlogon.exe is replaced before Windows XP restarts. However, the DLL files that the new version of Winlogon.exe needs are not replaced until Windows XP restarts.

When the Remote Desktop session is disconnected, reconnection attempts use the new version of Winlogon.exe. Winlogon.exe does not work because the files this new version of Winlogon.exe needs are not yet installed.

RESOLUTION

To work around this problem, use one of the following methods:

After You Try to Install Windows XP SP1

  1. Log on to the remote computer locally.
  2. Click OK on any error messages you receive.
  3. Click Finish on the Completing the Windows XP Service Pack 1 Setup Wizard dialog box to restart Windows and complete the Windows XP SP1 installation.

Before You Try to Install Windows XP SP1

To avoid this problem when you install Windows XP SP1, use either of the following methods:
  • Install Windows XP SP1 locally.
  • Use the network installation package and run the xpsp1.exe /f /q command. This command installs Windows XP SP1 "quietly" (/q) and quits other programs before it restarts your computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how to obtain Windows XP SP1, click the article number below to view the article in the Microsoft Knowledge Base:

322389 How to Obtain the Latest Windows XP Service Pack


Modification Type:MajorLast Reviewed:9/18/2002
Keywords:kbbug kberrmsg KB328930