Computer Cannot Recognize CompactFlash Card After You Plug It into PCMCIA Slot (328772)



The information in this article applies to:

  • Microsoft Windows Millennium Edition

This article was previously published under Q328772

SYMPTOMS

If you plug a CompactFlash card into the PCMCIA slot of a computer that runs Windows Millennium Edition, the Standard IDE/ESDI Hard Disk Controller device appears in the Device Manager list, but it appears with a yellow exclamation point over it. If you right-click the device and then click Properties, the following message appears in the Device status box:

This device is either not present, not working properly, or does not have all the drivers installed. (Code 10.)

Try upgrading the device drivers for this device.

CAUSE

When you install the CompactFlash card, Windows tries to rebalance the resources so that the device has its own interrupt request (IRQ). This attempt does not succeed, and the device shares IRQ 10 instead. This condition causes a hardware conflict that prevents Windows from recognizing the CompactFlash card.

WORKAROUND

To work around this problem, use Device Manager to manually set the IRQ for the LPT1 printer port to 10, and then restart the computer. To do so:
  1. Make sure that the CompactFlash card is plugged into the PCMCIA slot.
  2. Right-click the My Computer icon on the desktop, click Properties, and then click the Device Manager tab.
  3. Expand Ports.
  4. Double-click ECP Printer Port, and then click the Resources tab.
  5. Under Resource type, double-click Interrupt Request.
  6. In the Value box, click 10, and then click OK.

    A "Conflict Warning" message appears. Click Yes to continue.
  7. In the Properties dialog box, click OK.
  8. Click Yes to continue.
  9. Click Yes to shut down the computer.
  10. Restart the computer.
  11. Right-click the My Computer icon on the desktop, click Properties, and then click the Device Manager tab.
  12. Expand Hard disk controllers.

    Note that the yellow exclamation point no longer appears next to the Standard IDE/ESDI Hard Disk Controller device.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:1/14/2006
Keywords:kbnofix kbprb KB328772