You may receive a c1038a21 error message when you try to use Exchange System Manager to look at the properties of a public folder (328740)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server

This article was previously published under Q328740

SYMPTOMS

In Microsoft Exchange Server, when you try to use Exchange System Manager to look at the properties of a public folder, you may receive the following error message:
The mail proxy for this folder cannot be found. This may be due to replication delays. The mail enabled pages will not be shown. ID no: c1038a21

CAUSE

This issue may occur if the PR_PF_PROXY property for the folder in the information store contains a GUID that does not match the objectGUID property of the directory object for the folder in the Exchange System Objects container. This behavior typically occurs if a public folder proxy object in the Exchange System Objects container is deleted manually, and if the Active Directory Connector (ADC) is then used to create a new directory object for the folder.

When you use Exchange System Manager to look at the properties of a folder, Exchange System Manager retrieves the GUID from the PR_PF_PROXY property on the folder. (This property is kept in the public information store). Exchange System Manager queries a domain controller for that GUID and then retrieves the mail attributes from the matching object. If the domain controller cannot find an object that matches that GUID, the mail proxy error is returned.

If the PR_PF_PROXY property is empty, Exchange System Manager queries Active Directory directory service for an object that has a matching legacyExchangeDN attribute, and then Exchange System Manager retrieves the mail-enabled properties from the matching object. If Exchange System Manager cannot find an object that has a matching legacyExchangeDN attribute, you receive the error message that is described in the Symptoms section.

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1

Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.
  1. Use the latest version of the Information Store Viewer (also known as MDBVu32) to view the PR_PF_PROXY property and to determine whether an empty the PR_PF_PROXY property is the cause of the issue. To download the latest version Information Store Viewer, visit the following Microsoft Web site:
  2. In Information Store Viewer, find the folder that you want, and then look in the list of properties for the PR_PF_PROXY property. If the PR_PF_PROXY property is not in the list of properties, it is not populated on that folder in the store.
  3. If the PR_PF_PROXY property is present, start ADSI Edit, find the directory object for the folder under Microsoft Exchange System Objects, and look at the ObjectGUID of that object.
  4. If the PR_PF_PROXY property is set, and if the GUID does not match the objectGUID property of the active directory object, this may be the problem.

    You can also use the LDP.exe tool to query Active Directory for the GUID that is shown in the PR_PF_PROXY property. To do this, follow these steps:
    1. At a command prompt, type ldp.exe.
    2. Click Connection\Connect, and then type the name of a domain controller in your domain.
    3. Click Connection\Bind. If you are logged on with a domain account, leave all text boxes blank.
    4. Click View, and then click Tree. Make sure that the text box is empty, and then press ENTER.
    5. In the Base DN box, type GUID=NNNN, where NNNN is the GUID that Exchange System Manager is querying for.
  5. If you determine that a directory object does exist for the folder but that the objectGUID does not match the GUID in the PR_PF_PROXY property, you can use Information Store Viewer to delete the PR_PF_PROXY property from the folder. This will correct the error because when the PR_PF_PROXY property is empty, Exchange System Manager will search based on the legacyExchangeDN attribute instead of searching based on the objectGUID property. To delete the PR_PF_PROXY property, after you have the properties of the folder that you want in the Information Store Viewer, click Property Interface, and then click DeleteProps. In the list of properties, click PR_PF_PROXY, click Add, and then click Call.

Method 2

In some Exchange organizations, you can resolve this problem by using Exchange System Manager to mail-enable the folders again. You can use method 2 if the following conditions are true:
  • The Exchange organization contains only computers that run Exchange 2000 Server or later versions.
  • There is no longer an ADC in the Exchange organization.
A new directory object is created, and the new GUID is stamped in the PR_PF_PROXY property. If the old directory object still exists, you must delete it manually. If Exchange 5.5 Server computers still exist anywhere in the Exchange organization, do not mail-enable public folders by use Exchange System Manager.

MORE INFORMATION

In an Exchange organization that contains Exchange 5.5 servers, typically most of the public folders will not have the PR_PF_PROXY property populated. The typical way to populate the PR_PF_PROXY property is by using Exchange System Manager to mail-enable the public folder. A public folder may have been mail-enabled automatically because of the existence of an ADC with a public folder connection agreement; this is the typical situation in a mixed Exchange Server environment that includes Exchange Server 5.5, Exchange 2000 Server, and later versions. If this is the case, the PR_PF_PROXY property typically will not be set on the folder. However, there are situations where the store may actively synchronize the PR_PF_PROXY property with the directory object, such as when Send As permission is granted on the folder. Therefore, you may find sometimes that the PR_PF_PROXY property is populated even though all the proxy objects were created by the ADC.

The PR_PF_PROXY property may appear to contain a value even when it actually does not. For example, if you use the MAPI GetProps call, and if you request the PR_PF_PROXY property, a value may be returned even when calling GetPropsList does not list the PR_PF_PROXY property. This behavior occurs because when the PR_PF_PROXY property is not populated, if that property is specifically requested, the store will query for the legacyExchangeDN attribute of the folder and then return the objectGUID property of the matching directory object. This may cause unexpected behavior when you use different utilities to view and to modify the PR_PF_PROXY property , because the PR_PF_PROXY property may appear to be populated even after the PR_PF_PROXY property has been emptied. The list of folder properties in Information Store Viewer accurately reflects whether the PR_PF_PROXY property truly contains a value.

The problem that is described in the Symptoms section can occur whenever the PR_PF_PROXY property is populated with a GUID, and whenever the corresponding directory object is subsequently deleted or cannot be found by Exchange System Manager for other reasons, such as permissions or replication problems. Even if the PR_PF_PROXY property is empty, the same problem will occur if Exchange System Manager cannot find the matching legacyExchangeDN attribute for similar reasons.

Note The Information Store Viewer that is included in Exchange 2000 Server and in the Exchange 2000 Server service packs does not recognize the PR_PF_PROXY property. The latest version of the Information Store Viewer works with both Exchange 2000 Server and Exchange Server 2003.

For more information about other issues that may cause a c1038a21 error, click the following article number to view the article in the Microsoft Knowledge Base:

278441 Error c1038a21 occurs when you open the properties of a public folder


Modification Type:MinorLast Reviewed:11/10/2005
Keywords:kbprb KB328740