Internet Zone Credential Policy Applied to Intranet Zone If Redirect Occurs (328502)



The information in this article applies to:

  • Microsoft Internet Explorer version 6 for Windows XP
  • Microsoft Internet Explorer version 6 for Windows 2000
  • Microsoft Internet Explorer version 6 for Windows NT 4.0
  • Microsoft Internet Explorer version 6 for Windows Millennium Edition
  • Microsoft Internet Explorer version 6 for Windows 98 Second Edition
  • Microsoft Internet Explorer version 6 for Windows 98
  • Microsoft Internet Explorer version 6 for Windows XP SP1
  • Microsoft Internet Explorer version 6 for Windows 2000 SP1
  • Microsoft Internet Explorer version 6 for Windows Millennium Edition SP1
  • Microsoft Internet Explorer version 6 for Windows NT 4.0 SP1
  • Microsoft Internet Explorer version 6 for Windows 98 Second Edition SP1
  • Microsoft Internet Explorer version 6 for Windows 98 SP1

This article was previously published under Q328502

SYMPTOMS

When Internet Explorer is redirected from one zone to a second zone, the credential policy for the first zone are applied to the second zone site.

Example

If a redirect occurs from an Internet site to an intranet site and the intranet site requires authentication, the Internet zone policy is applied, and you are prompted for your user name and password.

CAUSE

This is caused by a code defect during the redirect code where the Credentials Policy is not re-evaluated based on the new site.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Internet Explorer 6 service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

For Internet Explorer 6.0

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name
   ----------------------------------------------------------
   11-Sep-2002  14:11  6.0.2721.1100     585,216  Wininet.dll
				

For Internet Explorer 6.0 Service Pack 1

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name
   ----------------------------------------------------------
   23-Oct-2002  14:30  6.0.2800.1130     585,728  Wininet.dll
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbenv kbfix kbprb kbQFE kbui KB328502