XADM: ESM Returns Error Message "c1041722" If You Mount a Database After You Rename the Storage Group (328359)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q328359

SYMPTOMS

If you mount a database after the Storage Group where this database resides is renamed, you receive the following error message from Exchange System Manager (ESM):
The Microsoft Exchange Information Store service Could not find the specified object.
ID no: c1041722
Exchange System Manager

CAUSE

This is cause by the DSAccess cache; the cache has not been flushed. When the information store queries for the distinguished name (DN) of the Messaging Database (MDB), the old DN of MDB is returned. When you mount an MDB, Microsoft Exchange Server explicitly check the DN of the MDB with that of the storage group. If the DNs do not match, the mount is unsuccessful.

WORKAROUND

Before you mount the database, wait for the DSAccess cache to expire. The default time-to-live (TTL) is 15 minutes. Mount the database before you rename the Storage Group.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbbug KB328359