Computer hangs during shutdown or restart if multiple programs call ExitWindowsEx() (327565)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

This article was previously published under Q327565

SYMPTOMS

If two or more programs try to shut down or restart Windows, the computer may stop responding (hang) while it is shutting down. The desktop wallpaper may be visible and the mouse pointer may move, but the computer may not respond to keyboard input (including the CTRL+ALT+DELETE key combination). You might have to turn off the computer to continue.

CAUSE

If multiple programs call the ExitWindowsEx function to shut down or restart Windows at almost the same time, one of the shutdown messages may be discarded incorrectly. When this occurs, the shutdown process does not complete.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Note There is no Windows 2000 hotfix available for this problem.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size       File name
   -------------------------------------------------------
   22-Aug-2002  19:16  5.1.2600.100  1,671,040  Win32k.sys
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB327565