Error message when you install Exchange 2000 Server SP3: "Setup failed while Creating IIS Metabase objects for Base DAV protocol (error 0x8009000F: Object already exists.)" (327183)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Internet Information Services 5.0

This article was previously published under Q327183

SYMPTOMS

When you install Microsoft Exchange 2000 Server Service Pack 3 (SP3), you may receive the following error message:
Setup failed while Creating IIS Metabase objects for Base DAV protocol (error 0x8009000F: Object already exists.) .

Additional information: The specified service does not exist as an installed service.

Facility: Win32 ID no: c0070424 Microsoft Exchange Setup

Path = 'IIS://SERVER/W3SVC/1'

Object already exists.

ID no: 8009000f Microsoft Exchange Setup
mode = 'Update' (61957)
Path = 'IIS://SERVER/W3SVC/1'
mode = 'Update' (61957)
Setup encountered an error during Microsoft Exchange Messaging and Collaboration Services of Update component task.

Function:
CService::ScGetDependendentServices
CMetabaseKey::ScOpen
CAtomDAV::ScAddMetabaseKeys
CAtomDAV::ScServicePackUpdate
CBaseAtom::ScSetup
CMetabaseKey::ScOpen
CAtomDAV::ScAddMetabaseKeys
CAtomDAV::ScServicePackUpdate
CBaseAtom::ScSetup
CBaseComponent::ScSetup
CBaseComponent::ScSetup
CCompServer::ScSetup
CComExchSetupComponent::Install
Additionally, the following text is logged in the Exchange Server Setup Progress.log file:
[01:33:58] Creating IIS Metabase objects for Base DAV protocol
[01:33:58] Entering CAtomBaseDAV::ScFixISAPIRestrictionList
[01:33:58] Setup detected that the IIS version was below IIS6 - skipping
ISAPIRestrictionList settings.
[01:33:58] Leaving CAtomBaseDAV::ScFixISAPIRestrictionList
[01:33:58] Leaving CAtomBaseDAV::ScAddMetabaseKeys
[01:33:58] Entering CMetabaseKey::ScOpen
[01:34:11] Path = 'IIS://CINMLEP01/W3SVC/1' CMetabaseKey::ScOpen
(y:\admin\src\libs\exsetup\mbob.cxx:52)
Error code 0X8009000F (15): Object already exists.
[01:34:11] Leaving CMetabaseKey::ScOpen
[01:34:11] CAtomDAV::ScAddMetabaseKeys
(y:\admin\src\udog\exsetdata\components\server\a_dav.cxx:824)
Error code 0X8009000F (15): Object already exists.
[01:34:11] Leaving CAtomDAV::ScAddMetabaseKeys
[01:34:11] CAtomDAV::ScServicePackUpdate
(y:\admin\src\udog\exsetdata\components\server\a_dav.cxx:592)
Error code 0X8009000F (15): Object already exists.
[01:34:11] Leaving CAtomDAV::ScServicePackUpdate
[01:34:11] mode = 'Update' (61957) CBaseAtom::ScSetup
(y:\admin\src\udog\setupbase\basecomp\baseatom.cxx:788)
Error code 0X8009000F (15): Object already exists.
[01:37:10] ***** RETRYING THE FAILED OPERATION *****
[01:37:10] Beginning Update of Base DAV protocol sub-component
[01:37:10] Entering CAtomDAV::ScServicePackUpdate
[01:37:10] Entering CBaseAtom(Base DAV protocol)::ScServicePackUpdate
[01:37:10] Leaving CBaseAtom(Base DAV protocol)::ScServicePackUpdate
[01:37:10] Entering CAtomDAV::ScAddMetabaseKeys
[01:37:10] Entering CAtomBaseDAV::ScAddMetabaseKeys
[01:37:10] Creating IIS Metabase objects for Base DAV protocol
[01:37:10] Entering CAtomBaseDAV::ScFixISAPIRestrictionList
[01:37:10] Setup detected that the IIS version was below IIS6 - skipping
ISAPIRestrictionList settings.
[01:37:10] Leaving CAtomBaseDAV::ScFixISAPIRestrictionList
[01:37:10] Leaving CAtomBaseDAV::ScAddMetabaseKeys
[01:37:10] Entering CMetabaseKey::ScOpen
[01:37:23] Path = 'IIS://SERVER/W3SVC/1' CMetabaseKey::ScOpen
(y:\admin\src\libs\exsetup\mbob.cxx:52)
Error code 0X8009000F (15): Object already exists.
[01:37:23] Leaving CMetabaseKey::ScOpen
[01:37:23] CAtomDAV::ScAddMetabaseKeys
(y:\admin\src\udog\exsetdata\components\server\a_dav.cxx:824)
Error code 0X8009000F (15): Object already exists.
[01:37:23] Leaving CAtomDAV::ScAddMetabaseKeys
[01:37:23] CAtomDAV::ScServicePackUpdate
(y:\admin\src\udog\exsetdata\components\server\a_dav.cxx:592)
Error code 0X8009000F (15): Object already exists.
[01:37:23] Leaving CAtomDAV::ScServicePackUpdate
[01:37:23] mode = 'Update' (61957) CBaseAtom::ScSetup
(y:\admin\src\udog\setupbase\basecomp\baseatom.cxx:788)
Error code 0X8009000F (15): Object already exists.
When you try to start Internet Information Services (IIS) Manager, you may receive the following error message:
Unable to enumerate web sites because the following error occurred:
Object already exists
Note You may also receive this error message when you try to access the Administration Web site.

Additionally, you may receive the following error message in the Administrator tool:
Unable to connect to the Active Directory Service Object. Please contact your system administrator. Error:-2146893809
When you receive this error message, no Web sites or services appear in IIS Manager.

CAUSE

This issue may occur if the permissions to the keys that are located in the Machinekeys folder have been changed.

RESOLUTION

To resolve this issue, follow these steps:
  1. In Windows Explorer, right-click the Machinekeys folder, and then click Properties.

    Note The Machinekeys folder is located at the following folder path:

    Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\Machinekeys

    This folder path may contain hidden folders. To view these hidden folders, follow these steps:
    1. On the Tools menu, click Folder options.
    2. Click the View tab, and then click Show hidden files and folders under Advanced settings.
  2. Click the Security tab.
  3. Click Add.
  4. In the Look In dialog box, click the local computer.
  5. Add the Administrators group, and then give this group Full Control permissions.
  6. Click Advanced, and then click Add.
  7. Click the Everyone group, and then click OK.
  8. Make sure that the following check boxes are selected:
    • List Folder / Read Data
    • Read Attributes
    • Read Extended Attributes
    • Create Files / Write Data
    • Create Folders / Append Data
    • Write Attributes
    • Write Extended Attributes
    • Read Permissions
    Note By default, these check boxes are selected.
  9. Click OK.
  10. Click to select the Reset Permissions on all Child objects and enable propagation of inheritable permissions check box.

MORE INFORMATION

A similar issue has been reported in which the System Attendant does not start. This issue occurs because the permissions to the keys that are located in the Machinekeys folder have been changed or are corrupted. For more information about this issue, click the following article number to view the article in the Microsoft Knowledge Base:

280432 System Attendant stops working with a 9022 event


Modification Type:MinorLast Reviewed:3/9/2006
Keywords:kbExpertiseAdvanced kbtshoot kbprb KB327183