PRB: Cannot Re-Import Adventure Works After You Have Deleted It (326760)



The information in this article applies to:

  • Microsoft Commerce Server 2002

This article was previously published under Q326760

SYMPTOMS

When you try to import the Adventure Works sample catalog or another product catalog, you may receive the following error message in the event log:
Commerce Server: The XML Schema Definition for the Category or Product Definition 'Backpack' does not match the actual definition in the Catalog System. You need to either correct the XML Schema Definition in the XML file or modify the existing definition in the catalog system.

CAUSE

This problem occurs because the product definition that is defined in the Commerce Server catalog system does not match the product definition that is defined in the product catalog file that you want to import.

RESOLUTION

To resolve this problem, change the product definition to match the definition that appears in the XML catalog file before you import the product catalog.

MORE INFORMATION

Steps to Reproduce the Behavior

To reproduce the problem, follow these steps:
  1. From the BizDesk for a Commerce Server site, open the Catalog Editor.
  2. Import the sample product catalog Adventure Works.
  3. In the Catalog Designer, select the product definitions, and then add a new property to the Back Pack product definition.
  4. Open the Adventure Works catalog, and then create a new Back Pack product. Close the catalog.
  5. Delete this Adventure Works product catalog.
  6. From the Catalog Editor, try to import the Adventure Works catalog again.

Modification Type:MajorLast Reviewed:12/27/2002
Keywords:kbprb KB326760