Cannot access network resources after you establish a Dial-up Networking connection and log on to the domain (326570)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows XP 64-Bit Edition Version 2002 SP1

This article was previously published under Q326570

SYMPTOMS

After you establish a Dial-Up Networking connection and log on to the server using your domain user name and password, and you try to access a domain resource, you may be prompted to enter your domain user name and password or you may be denied access to the resource.

CAUSE

This problem may occur when your Internet service provider (ISP) credentials are incorrectly used for authentication instead of your domain credentials. Your credentials for the dial-up networking connection to the Internet are stored in Stored User Names and Passwords. This occurs when these credentials override your cached domain credentials that are also stored in Stored User Names and Passwords.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP SP1

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   02-Dec-2002  22:18  5.1.2600.1145     631,808  Rasdlg.dll       

Windows XP 64-Bit Edition Version 2002 SP1

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   02-Dec-2002  22:18  5.1.2600.1145   1,483,264  Rasdlg.dll       IA64
   26-Nov-2002  19:41  5.1.2600.1145     631,808  Wrasdlg.dll      X86

Note To install this hotfix, you must be running Windows XP Service Pack 1 (SP1). Windows XP Tablet PC Edition and Windows XP Media Center Edition include SP1. You must apply this hotfix and then re-create your Dial-Up Networking connections for this hotfix to work properly.


WORKAROUND

To work around this problem, use the Connection Manager Administration Kit (CMAK) wizard to create a custom Connection Manager profile for your Dial-Up Networking connection to the Internet. Make sure that you use the following settings in the profile:
  • Server&EntryName (where EntryName is the name of the dial-up networking connection entry)
  • Set the DontUseRasCredentials key to 1
The DontUseRasCredentials key specifies whether to cache credentials in Stored User Names and Passwords for use when accessing resources after logging onto the network. When you set this key to a value of 1, user credentials are not cached.

For more information about the Windows Server 2003 Connection Manager Administration Kit, visit the following Microsoft Web site:

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

To install this hotfix, you must be running Windows XP Service Pack 1 (SP1). Windows XP Tablet PC Edition and Windows XP Media Center Edition include SP1. You must apply this hotfix and then recreate your Dial-Up Networking connections for this hotfix to work properly.

Modification Type:MajorLast Reviewed:6/21/2006
Keywords:kbHotfixServer kbQFE kbQFE kbbug kbfix KB326570