OL2000: Contacts Do Not Resolve Correctly When You Compose a New Message (326149)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q326149

SYMPTOMS

If you enter a recipient name in the To, Cc, or Bcc box of a new message in Outlook 2000, the recipient name does not resolve correctly although the name is unique and in your Contacts list.

CAUSE

This problem may occur when there is another contact with a fax address that contains the same name.

The following is an example that describes how this problem occurs.

You have two contacts, one is named Jane Doe and the other is named John Doe. Jane Doe has a business fax e-mail address of "Jane Doe@ (555) 555-1212" (without quotation marks), while John Doe has a Simple Mail Transfer Protocol (SMTP) e-mail address of "johndoe@somewhere.com" (without quotation marks).

If the business fax address for Jane Doe is "Jane and John Doe@ (555) 555-1212" (without quotation marks), then the Address Book displays the following entries for Jane Doe and John Doe:
   Name       Display Name      E-mail Address         E-mail Type
   ---------------------------------------------------------------
   Jane Doe   Jane Doe          Jane and John          Fax
              (Business Fax)    Doe@ (555) 555-1212
   ---------------------------------------------------------------
   John Doe   John Doe          johndoe@somewhere.com  SMTP
              (Doe, John)
  
				
In this example, the name "John Doe" (without quotation marks) would not be unique although you expect it to be.

If the contact name "Jane Doe" (without quotation marks) was originally "Jane and John Doe" (without quotation marks), and was later changed to just "Jane Doe"(without quotation marks), the business fax e-mail address may remain as "Jane and John Doe@(555) 555-1212" (without quotation marks).

A known cause for this problem is described in the following Microsoft Knowledge Base article:

265866 OL2000: Fax Addresses for Your Contacts Are Not Updated Correctly

RESOLUTION

Microsoft has created an update that prevents this problem.For additional information about the update and how to determine if you already have the update installed on your computer, click the article number below to view the article in the Microsoft Knowledge Base:

265866 OL2000: Fax Addresses for Your Contacts Are Not Updated Correctly

WORKAROUND

To work around this problem, correct any fax addresses in your existing Contacts folder that experience this problem.

To correct the fax address, use one of the following methods.

Method 1: Change the Fax Number in the Contact

  1. Locate the contact that has the incorrect fax entry in the Address Book.
  2. Open the contact.
  3. Delete the fax number.
  4. Click Save and Close.
  5. Open the contact again, and then type the fax number.
  6. Click Save and Close.
  7. Check the Address Book to verify that the fax entry for the contact is now correct.

Method 2: Export and Import Existing Contacts

  1. On the File menu, click Import and Export.
  2. In the Import and Export Wizard dialog box, click to select the Export to file check box under Choose and action to perform, and then click Next.
  3. In the Export to file dialog box under Create a file of type, click any file type, except for personal folders (.pst) file (for example, click Tab Separated Values (Windows)), and then click Next.

    NOTE: Exporting the contacts as a .pst does not correct the problem.
  4. Under Select folder to export from, click the Contacts folder that you want to export to, and then click Next.
  5. Under Save exported file as, type the path and file name that you want to create, and then click Next.
  6. Verify the actions to be performed are correct, and then click Finish.

    NOTE: At this point, you must create a new Contacts folder to which you want to import the file that you created to, or delete the contents of the current Contacts folder.
  7. On the File menu, click Import and Export.
  8. In the Import and Export Wizard dialog box, click to select the Import from another program or file check box under Choose and action to perform, and then click Next.
  9. Under Select file type to import from, click to select the type of file that you created when you exported the contacts, and then click Next.
  10. Under File to import, type the path and name of the file that you want to import, and then click Next.
  11. Under Select destination folder, click to select the folder to which the data is to be imported to, and then click Next.
  12. Click Finish.
  13. Check the Address Book to verify that the fax entry for the contact is now correct.

Important Note

If you refresh your contacts from another source and you still experience this problem, you must update the other source to resolve the problem.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:9/29/2003
Keywords:kbbug kbnofix KB326149