RA_MaxTicketExpiry Entry in the Unattend.txt File Does Not Work Correctly (323267)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q323267
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

Under the following conditions, the Remote Assistance maximum ticket expiration may not be set as you expect:
  • You run an unattended installation of Windows XP.
  • You use the RA_MaxTicketExpiry entry in the [PCHealth] section of the Unattend.txt file.
Although you use RA_MaxTicketExpiry entry, the Remote Assistance maximum ticket expiration is set to 30 days.

CAUSE

This problem occurs because the RA_MaxTicketExpiry unattended installation parameter does not work as documented.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. To work around this problem, use a registry (.reg) file to set the maximum Remote Assistance ticket expiration length. To do so, you must set two registry values:
  • HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\MaxExpiryUnits

    This is a DWORD value that indicates what units express the maximum ticket expiration parameter. A value of 0 indicates minutes, a value of 1 indicates hours, and a value of 2 indicates days.
  • HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\MaxTicketExpiry

    This is a DWORD value that indicates the maximum number of time units that a Remote Assistance invitation can remain open.

Examples

To limit the maximum time that a Remote Assistance invitation can remain open to 3 hours, set MaxExpiryUnits to 1 (indicating hours), and MaxTicketExpiry to 3. To set 12 days, set MaxExpiryUnits to 2 (indicating days), and MaxTicketExpiry to 12.

You can use the Cmdlines.txt feature of an unattended installation to insert these registry entries. For example, you might use a command that is similar to the following command:

"regedit /s C:\path to your .reg file\file name.reg"

Note that your command must be enclosed in quotation marks.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

By default, the Remote Assistance maximum ticket expiration is 30 days.

Modification Type:MajorLast Reviewed:8/15/2003
Keywords:kbbug kbdocerr kbenv kbnofix kbsetup KB323267