XADM: Exchange 2000 Server Cannot Register Outlook New Mail Notifications (319572)



The information in this article applies to:

  • Microsoft Exchange 2000 Server, when used with:
    • the operating system: Microsoft Windows 2000

This article was previously published under Q319572
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

It may appear that Microsoft Outlook does not receive new e-mail messages. However, only new mail notifications are not being received.

If you click another folder, and then click the Inbox, new messages are received. If you wait one minute, new mail is received.

NOTE: If the new mail notification is not registered, Outlook polls the server every minute to see if there is new mail.

CAUSE

The two common causes of this issue are:
  • The server cannot register the client new mail notifications.
  • UDP traffic is not transferred from the server to the client computer.
New mail notifications rely on User Datagram Protocol (UDP) and a valid registration from the server.

RESOLUTION

Server New Mail Notification Registration

If the mail server cannot register the client for new mail notifications, you can use several tools to resolve the issue.

The Regedt32 Program

You can use the Regedt32 program to resolve this issue.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

When a client sends the request to the server to register for new mail notifications, the information store uses several registry keys.

The first key is:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock\Parameters\Transports

The value in the Transports key is matched with the corresponding Services registry keys.

For example, if the values for the Transports key are Tcpip, NetBIOS, and AppleTalk, the corresponding registry keys are:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBIOS

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AppleTalk

If all the values in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock\Parameters\Transports registry key do not have corresponding Services keys, the new mail notification does not work.

The EnumProt Program

To determine if there are any issues on the server, run the EnumProt program. To run this utility:
  1. Save the EnumProt.exe file to the Exchange 2000 server.
  2. From a command line, locate the folder where you saved EnumProt.exe.
  3. Type EnumProt > EnumProt.txt.
  4. Open the EnumProt.txt file to see whether the test succeeded.
The following sample is a successful test:

Testing for "TCPIP Support"! AF_INET = Family (2)
Calling EnumProtocols() with 2048 byte buffer.
Dumping available transports [8]

1 - Protocol: Family (2) Protocol (0x6) TCP/IP
2 - Protocol: Family (2) Protocol (0x11) UDP/IP
3 - Protocol: Family (17) Protocol (0x80000000) \Device\NetBT_Tcpip_{EBDFB267-726B-44D0-8151-991AADA9CC48}
4 - Protocol: Family (17) Protocol (0x80000000) \Device\NetBT_Tcpip_{EBDFB267-726B-44D0-8151-991AADA9CC48}
5 - Protocol: Family (17) Protocol (0xffffffff) \Device\NetBT_Tcpip_{940E55D2-C11F-4FAF-8D9A-DE8420445A8E}
6 - Protocol: Family (17) Protocol (0xffffffff) \Device\NetBT_Tcpip_{940E55D2-C11F-4FAF-8D9A-DE8420445A8E}
7 - Protocol: Family (17) Protocol (0xfffffffe) \Device\NetBT_Tcpip_{D8272D57-6520-460F-9F37-984EAE14BBD0}
8 - Protocol: Family (17) Protocol (0xfffffffe) \Device\NetBT_Tcpip_{D8272D57-6520-460F-9F37-984EAE14BBD0}
SUCCEEDED!

The following sample is an unsuccessful test:

Testing for "TCPIP Support"! AF_INET = Family (2)
Calling EnumProtocols() with 2048 byte buffer.
Error returned! GetLastError() = 0x2
FAILED! Returned 0x80040102

The DPMon Program

Run the DPMon program on the client computer during the Outlook logon process. The new mail notification is represented by:

CNCT::EcOpenSocketAndRegisterForNotifications

If the server cannot register the new mail notification, the following error is generated:
ec=ecNotSupported-MAPI_E_NO_SUPPORT (0x80040102)
NOTE: If the new mail notification is not registered, the client polls the server every minute to see if there is new mail.

UDP Traffic

Network Monitor You can use Network Monitor to determine whether UDP packets are sent. To determine whether UDP packets are sent between the server and the client, capture the Outlook logon process. Also capture the process of sending a new message to the client. If no UDP packets are sent from the server, either UDP is being blocked or the registration was not successful on the server.

NOTE: The client binds to the information store (A4F1DB00-CA47-1067-B31F-00DD010662DA). Then send an opnum 0x4 (ecRRegisterPushNotification) to the server. The server responds successfully to this opnum 0x4, whether the client is registered or not.

For additional information about using Network Monitor to troubleshoot client connectivity, see the "Client Network Traffic with Exchange 2000" white paper at the following Microsoft Web site:

WORKAROUND

To work around this issue if the registry keys are mismatched, manually modify the Winsock parameters. To do so, you have to modify the registry.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To manually modify the Winsock parameters:
  1. Click Start, and then click Run. Type RegEdt32, and then click OK.
  2. Locate the following key in the registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock\Parameters

  3. Double-click Transports.
  4. If one or more of the values do not have a corresponding Services registry key (for example, HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AppleTalk), delete the value.
  5. Restart the server
  6. Make sure that the clients receive new mail notifications

NOTE: Check the event log for error or warning messages that may be generated when you manually edit the registry.

MORE INFORMATION

UDP Failure

Common reasons to permit UDP traffic include:
  • A router is not allowing UDP packets between the server and the client. You have to configure the router to allow UDP packets to pass from the server to the client. To do so, view the router manufacturer's documentation.
  • A firewall is blocking the UDP ports from the server to the client. Open the ephemeral ports (1024 and higher) to allow UDP from the server to the client.
  • Cisco VPN clients that are earlier than version 4.0 disable the following WinSock registration:

    HKEY_CURRENT-USER\Software\Microsoft\Windows NT\currentVersion\Windows Messaging Subsystem\Profiles\<Microsoft Outlook profile name>\13dbb0c8aa05101a9bb000aa002fc45a

    There is a regBinary value:

    PR_DISABLE_WINSOCK. "00036618"=hex:01,00,00,00

For additional information about troubleshooting UDP, click the article number below to view the article in the Microsoft Knowledge Base:

264035 XADM: No Way to Configure Port for UDP New Mail Notification Packets


Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbprb KB319572