Error Message: The POP3 Connector Install Failed (319314)



The information in this article applies to:

  • Microsoft Small Business Server 2000

This article was previously published under Q319314
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

While you are installing the POP3 connector in Small Business Server (SBS) 2000 Maintenance mode, you may receive the following error message:
The POP3 Connector Install Failed
A red X may also appear next to the Small Business Server/Connectivity/POP3 Connector item when the installation is completed. The following text appears in the information box:
POP3 Install failed
If you run SBS 2000 integrated Setup in Maintenance mode again to install the POP3 connector, the same results occur.

CAUSE

A previous installation or removal of the POP3 Connector component may have left partial information on the server. This causes later installations not to work correctly.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Make sure that the Microsoft Connector for POP3 Mailboxes service (Vmimb.exe) is not running:
    1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
    2. Right-click Microsoft Connector for POP3 Mailboxes, and then click Stop.
  2. Confirm the absence of the MSPOP3Connector registry key:
    1. Click Start, click Run, type regedt32, and then click OK.
    2. Locate and then click the following registry key:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services

    3. If the MSPOP3Connector key exists, click the key and then press DELETE.
  3. Rename the Pop3 Connector folder:
    1. Locate the C:\Program Files\Microsoft BackOffice\Connectivity\POP3 Connector folder.
    2. Right-click the folder, and then click Rename.
    3. Rename the folder to POP3 Connector.Bad.
    4. Delete the Vmimb.exe file from the POP3 Connector.Bad folder. If you receive an "Access denied" error message, stop the Windows Management Instrumentation service before you delete the file.
  4. Delete all Sitxxxxx.tmp folders:
    1. Click Start, and then click Search.
    2. Type sit*.tmp, and then click OK.
    3. Select the resulting list of folders, and then press DELETE.
  5. Run the integrated installation for the POP3 Connector component.For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

    302548 How to Install the Small Business Server 2000 POP3 Connector After You Install Exchange 2000

  6. After you install the POP3 Connector component, delete the POP3 Connector.Bad folder that you created in step 3.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information, click the article numbers below to view the articles in the Microsoft Knowledge Base:

279985 SBS POP3 Connector Does Not Report Actual POP3 Server Errors

277890 SBS POP3 Connector Is Unable to Download E-Mail from MSN POP3 Accounts


Modification Type:MajorLast Reviewed:8/20/2002
Keywords:kberrmsg kbprb KB319314