PRB: "Interface Not Registered" Error Message When You Run a Test in Application Center Test (318956)



The information in this article applies to:

  • Microsoft Application Center Test, Developer Edition

This article was previously published under Q318956

SYMPTOMS

When you try to run a test in Microsoft Application Center Test (ACT), you may receive the following error message:
Microsoft Application Center Test
Could not start the test.
Interface not registered (0x80040155).

CAUSE

Windows Management Instrumentation (WMI) components may become unregistered during the installation of the Visual Studio .NET Framework. This problem may occur more often if you use a beta version of Visual Studio .NET.

RESOLUTION

At a command prompt, run Regsvr32 on all of the DLL files that are located in the WindowsDirectory\System32\Wbem folder on your computer.

MORE INFORMATION

To register all of the DLL files that are located in the WindowsDirectory\System32\Wbem folder on your computer, you can use the following automated procedure.

WARNING: This sample code is provided "as-is". Microsoft cannot be held liable for damages caused by this sample code.
  1. Create a file named Register.bat, and then place the file in the WindowsDirectory\System32\Wbem folder on your computer.
  2. Add the following line to the BAT file:

    for %%v in ( *.dll ) do regsvr32 /s %%v

  3. Run the BAT file.

Modification Type:MajorLast Reviewed:8/6/2002
Keywords:kbprb KB318956